summaryrefslogtreecommitdiffstats
path: root/meta-openpower/common/recipes-phosphor/ipmi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/common/recipes-phosphor/ipmi')
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb19
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config/config.yaml117
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native.bb19
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-sensor-inventory-mrw-native.bb16
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-sensor-inventory-mrw/openpower-config.yaml34
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-whitelist-native.bb6
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-whitelist/openpower-ipmi-oem-whitelist-native.conf2
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb35
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.inc5
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bbappend1
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/phosphor-logging-error-logs-native.bbappend1
11 files changed, 255 insertions, 0 deletions
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb b/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb
new file mode 100644
index 000000000..31aee2d7c
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Hostboot hostfw inventory map for phosphor-ipmi-fru"
+PR = "r1"
+
+inherit native
+inherit phosphor-ipmi-fru
+inherit obmc-phosphor-license
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-hostfw-config"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${hostfw_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config/config.yaml b/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config/config.yaml
new file mode 100644
index 000000000..2233913aa
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config/config.yaml
@@ -0,0 +1,117 @@
+PROC:
+ EntityID: 3
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Mfg Date"
+ Manufacturer:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Manufacturer"
+ PartNumber:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Part Number"
+ SerialNumber:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Serial Number"
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Name"
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruSection: Board
+ # Custom Field 2 is EC.
+ IPMIFruProperty: "Custom Field 2"
+ # Delimiter value in ascii as YAML parser
+ # was not allowing certain characters like ":" as value
+ IPMIFruValueDelimiter: "58"
+ xyz.openbmc_project.Inventory.Item.Cpu:
+
+SYS:
+ # same entity ID as it is Associated type of NODE
+ EntityID: 7
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ Model:
+ IPMIFruSection: Chassis
+ IPMIFruProperty: "Part Number"
+ SerialNumber:
+ IPMIFruSection: Chassis
+ IPMIFruProperty: "Serial Number"
+ xyz.openbmc_project.Inventory.Item.System:
+
+NODE:
+ EntityID: 7
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Mfg Date"
+ Manufacturer:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Manufacturer"
+ PartNumber:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Part Number"
+ SerialNumber:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Serial Number"
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Name"
+ xyz.openbmc_project.Inventory.Item.Board:
+ AssociatedTypes:
+ - SYS
+
+DIMM:
+ EntityID: 32
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Mfg Date"
+ Manufacturer:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Manufacturer"
+ PartNumber:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Part Number"
+ SerialNumber:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Serial Number"
+ Model:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Model Number"
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Name"
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Version"
+ xyz.openbmc_project.Inventory.Item.Dimm:
+
+MEMBUFF:
+ EntityID: 8
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Mfg Date"
+ Manufacturer:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Manufacturer"
+ PartNumber:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Part Number"
+ SerialNumber:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Serial Number"
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Name"
+ xyz.openbmc_project.Inventory.Item.MemoryBuffer:
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native.bb b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native.bb
new file mode 100644
index 000000000..b02976074
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Copy error yaml files to known path for elog parsing"
+
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-dbus-yaml
+
+require openpower-ipmi-oem.inc
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ SRC=${S}/org/open_power/OCC
+ DEST=${D}${yaml_dir}/org/open_power/OCC
+ install -d ${DEST}
+ install ${SRC}/Metrics.errors.yaml ${DEST}
+ install ${SRC}/Metrics.metadata.yaml ${DEST}
+}
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-sensor-inventory-mrw-native.bb b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-sensor-inventory-mrw-native.bb
new file mode 100644
index 000000000..3e434b52f
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-sensor-inventory-mrw-native.bb
@@ -0,0 +1,16 @@
+SUMMARY = "OEM sensor config for phosphor-host-ipmid"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-host
+
+SRC_URI += "file://openpower-config.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${sensor_yamldir}
+ install -d ${DEST}
+ install openpower-config.yaml ${DEST}/openpower-config.yaml
+}
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-sensor-inventory-mrw/openpower-config.yaml b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-sensor-inventory-mrw/openpower-config.yaml
new file mode 100644
index 000000000..cf61b0521
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-sensor-inventory-mrw/openpower-config.yaml
@@ -0,0 +1,34 @@
+occ_active_sensor:
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: assertion
+ mutability: Mutability::Write|Mutability::Read
+ sensorNamePattern: nameLeaf
+ interfaces:
+ org.open_power.OCC.Status:
+ OccActive:
+ Offsets:
+ 0x00:
+ type: "bool"
+ assert: "false"
+ deassert: "true"
+ 0x01:
+ type: "bool"
+ assert: "true"
+ deassert: "false"
+
+hb_volatile_sensor:
+ path: /org/open_power/control/volatile
+ serviceInterface: org.freedesktop.DBus.Properties
+ readingType: assertion
+ mutability: Mutability::Write|Mutability::Read
+ sensorNamePattern: nameLeaf
+ interfaces:
+ xyz.openbmc_project.Object.Enable:
+ Enabled:
+ Offsets:
+ 0x00:
+ type: "bool"
+ assert: false
+ 0x01:
+ type: "bool"
+ assert: true
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-whitelist-native.bb b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-whitelist-native.bb
new file mode 100644
index 000000000..425901894
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-whitelist-native.bb
@@ -0,0 +1,6 @@
+SUMMARY = "Whitelisted OpenBMC IPMI OEM commands"
+DESCRIPTION = "Whitelisted OpenBMC IPMI OEM commands for OpenPOWER based systems"
+
+inherit obmc-phosphor-license
+inherit native
+inherit phosphor-ipmi-host-whitelist \ No newline at end of file
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-whitelist/openpower-ipmi-oem-whitelist-native.conf b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-whitelist/openpower-ipmi-oem-whitelist-native.conf
new file mode 100644
index 000000000..402056c67
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem-whitelist/openpower-ipmi-oem-whitelist-native.conf
@@ -0,0 +1,2 @@
+#<NetFn>:<Command>
+0x3A:0xF0 //<OpenPower IBM OEM>:<Add Partial eSEL command>
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
new file mode 100644
index 000000000..118c1c2b0
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
+DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
+PR = "r1"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-license
+inherit obmc-phosphor-ipmiprovider-symlink
+inherit pythonnative
+
+require ${PN}.inc
+
+DEPENDS += "phosphor-ipmi-host"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "phosphor-logging"
+DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
+DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
+DEPENDS += "sdbus++-native"
+
+RDEPENDS_${PN} += " \
+ sdbusplus \
+ phosphor-logging \
+ openpower-dbus-interfaces \
+ phosphor-dbus-interfaces \
+ "
+
+TARGET_CFLAGS += "-fpic"
+
+HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.inc b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
new file mode 100644
index 000000000..784ff9c52
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
@@ -0,0 +1,5 @@
+HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
+SRCREV = "8fb3f03c0d34cfe89acb3f373fa820a53dc5ba35"
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bbappend b/meta-openpower/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bbappend
new file mode 100644
index 000000000..ad56a88cd
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bbappend
@@ -0,0 +1 @@
+OBMC_IPMI_SENSORS_PROVIDERS_append_df-openpower = " openpower-ipmi-oem-sensor-inventory-mrw-native"
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/phosphor-logging-error-logs-native.bbappend b/meta-openpower/common/recipes-phosphor/ipmi/phosphor-logging-error-logs-native.bbappend
new file mode 100644
index 000000000..00d44c886
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/phosphor-logging-error-logs-native.bbappend
@@ -0,0 +1 @@
+DEPENDS_append_df-openpower = " openpower-ipmi-oem-error-native"
OpenPOWER on IntegriCloud