summaryrefslogtreecommitdiffstats
path: root/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb')
-rw-r--r--meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
new file mode 100644
index 000000000..118c1c2b0
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
+DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
+PR = "r1"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-license
+inherit obmc-phosphor-ipmiprovider-symlink
+inherit pythonnative
+
+require ${PN}.inc
+
+DEPENDS += "phosphor-ipmi-host"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "phosphor-logging"
+DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
+DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
+DEPENDS += "sdbus++-native"
+
+RDEPENDS_${PN} += " \
+ sdbusplus \
+ phosphor-logging \
+ openpower-dbus-interfaces \
+ phosphor-dbus-interfaces \
+ "
+
+TARGET_CFLAGS += "-fpic"
+
+HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
OpenPOWER on IntegriCloud