summaryrefslogtreecommitdiffstats
path: root/meta-openpower/recipes-bsp
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 06:30:50 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-04 17:28:29 -0400
commitd3f78932cf6b3063caceacdae9ddd6ca30d48786 (patch)
tree765de745d26798d7a37340d2851b86b57cda7eb8 /meta-openpower/recipes-bsp
parentf1ade61b5994799a4cffca0c124b2ed36e640cbf (diff)
downloadtalos-openbmc-d3f78932cf6b3063caceacdae9ddd6ca30d48786.tar.gz
talos-openbmc-d3f78932cf6b3063caceacdae9ddd6ca30d48786.zip
meta-openpower: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-openpower is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-openpower rev: 2c8db5661cecd7e4cc20bcb96df76490e62cfb67) Change-Id: I415caaa28ec728f24e755ddb549012f24874fefe Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/recipes-bsp')
-rw-r--r--meta-openpower/recipes-bsp/ffs/ffs.inc17
-rw-r--r--meta-openpower/recipes-bsp/ffs/ffs_git.bb8
-rw-r--r--meta-openpower/recipes-bsp/fsidbg/fsidbg.bb18
-rw-r--r--meta-openpower/recipes-bsp/pdbg/pdbg/0001-CFAM-reg-0x2918-access-hack.patch34
-rw-r--r--meta-openpower/recipes-bsp/pdbg/pdbg_1.0.bb13
-rw-r--r--meta-openpower/recipes-bsp/skiboot/gard.bb5
-rw-r--r--meta-openpower/recipes-bsp/skiboot/pflash.bb8
-rw-r--r--meta-openpower/recipes-bsp/skiboot/skiboot.inc27
8 files changed, 130 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/ffs/ffs.inc b/meta-openpower/recipes-bsp/ffs/ffs.inc
new file mode 100644
index 000000000..f144884aa
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ffs/ffs.inc
@@ -0,0 +1,17 @@
+SUMMARY = "Tools for manipulating FFS flash images."
+DESCRIPTION = "FFS is the FSP Flash File Structure which is also currently \
+used on OpenPOWER machines for the flash layout."
+
+HOMEPAGE = "https://github.com/open-power/ffs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit autotools pkgconfig
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_BEFORE_PN += "${PN}-ecc ${PN}-deprecated"
+
+FILES_${PN}-ecc = "${bindir}/ecc"
+FILES_${PN}-deprecated = "${bindir}"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openpower/recipes-bsp/ffs/ffs_git.bb b/meta-openpower/recipes-bsp/ffs/ffs_git.bb
new file mode 100644
index 000000000..2340121bd
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ffs/ffs_git.bb
@@ -0,0 +1,8 @@
+require ffs.inc
+
+PV = "v0.1.0+git${SRCPV}"
+
+SRCREV = "3ec70fbc458e32eef0d0b1de79688b4dc48cbd57"
+SRC_URI += "git://github.com/open-power/ffs.git"
+
+S = "${WORKDIR}/git"
diff --git a/meta-openpower/recipes-bsp/fsidbg/fsidbg.bb b/meta-openpower/recipes-bsp/fsidbg/fsidbg.bb
new file mode 100644
index 000000000..b6fed556a
--- /dev/null
+++ b/meta-openpower/recipes-bsp/fsidbg/fsidbg.bb
@@ -0,0 +1,18 @@
+SUMMARY = "FSI debug tool"
+DESCRIPTION = "fsidbg is a tool to access remote FSI engines and perform client driver operations"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
+
+SRC_URI += "git://github.com/eddiejames/fsidbg.git"
+
+SRCREV = "dfe278065c877724242dfae15a4c627fd2e3611c"
+PV = "git${SRCREV}"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 fsidbg ${D}${bindir}
+}
+
+TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/meta-openpower/recipes-bsp/pdbg/pdbg/0001-CFAM-reg-0x2918-access-hack.patch b/meta-openpower/recipes-bsp/pdbg/pdbg/0001-CFAM-reg-0x2918-access-hack.patch
new file mode 100644
index 000000000..dba62e3fe
--- /dev/null
+++ b/meta-openpower/recipes-bsp/pdbg/pdbg/0001-CFAM-reg-0x2918-access-hack.patch
@@ -0,0 +1,34 @@
+From e21d90ae8c131eae9d78e3d06f29cab55c952884 Mon Sep 17 00:00:00 2001
+From: Matt Spinler <spinler@us.ibm.com>
+Date: Thu, 19 Jan 2017 09:06:48 -0600
+Subject: [PATCH] CFAM reg 0x2918 access hack
+
+---
+ libpdbg/bmcfsi.c | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/libpdbg/bmcfsi.c b/libpdbg/bmcfsi.c
+index 64dbd69..f763f2a 100644
+--- a/libpdbg/bmcfsi.c
++++ b/libpdbg/bmcfsi.c
+@@ -247,7 +247,16 @@ static uint64_t fsi_abs_ar(uint32_t addr, int read)
+ /* Reformat the address. I'm not sure I fully understand this
+ * yet but we basically shift the bottom byte and add 0b01
+ * (for the write word?) */
+- addr = ((addr & 0x1fff00) | ((addr & 0xff) << 2)) << 1;
++
++ /* Hack: this shifting doesn't work for all addresses, but it does
++ * work for 2918 and (and 2nd chip 2918) so use it just for that */
++ if ((addr == 0x2918) || (addr == 0x102918)) {
++ addr = ((addr & 0x1ffe00) | ((addr & 0x1ff) << 2)) << 1;
++ }
++ else {
++ addr = ((addr & 0x1fff00) | ((addr & 0xff) << 2)) << 1;
++ }
++
+ addr |= 0x3;
+ addr |= slave_id << 26;
+ addr |= (0x8ULL | !!(read)) << 22;
+--
+2.11.0
+
diff --git a/meta-openpower/recipes-bsp/pdbg/pdbg_1.0.bb b/meta-openpower/recipes-bsp/pdbg/pdbg_1.0.bb
new file mode 100644
index 000000000..4d48a0ddf
--- /dev/null
+++ b/meta-openpower/recipes-bsp/pdbg/pdbg_1.0.bb
@@ -0,0 +1,13 @@
+SUMMARY = "PowerPC FSI Debugger"
+DESCRIPTION = "pdbg allows JTAG-like debugging of the host POWER processors"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI += "git://github.com/open-power/pdbg.git;branch=master"
+SRCREV = "3f1c06d62f81dfbfbb1723d15a6ff3c2f23708f1"
+
+DEPENDS += "dtc-native"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
diff --git a/meta-openpower/recipes-bsp/skiboot/gard.bb b/meta-openpower/recipes-bsp/skiboot/gard.bb
new file mode 100644
index 000000000..214e905ef
--- /dev/null
+++ b/meta-openpower/recipes-bsp/skiboot/gard.bb
@@ -0,0 +1,5 @@
+SUMMARY = "gard record tool for OpenPower"
+DESCRIPTION = "gard record tool for OpenPower machines"
+
+require skiboot.inc
+EXTRA_OEMAKE_append = " PFLASH_VERSION=${PV} GARD_VERSION=${PV}"
diff --git a/meta-openpower/recipes-bsp/skiboot/pflash.bb b/meta-openpower/recipes-bsp/skiboot/pflash.bb
new file mode 100644
index 000000000..05aa2fcca
--- /dev/null
+++ b/meta-openpower/recipes-bsp/skiboot/pflash.bb
@@ -0,0 +1,8 @@
+SUMMARY = "pflash programmer for OpenPower"
+DESCRIPTION = "pflash firmware programming tool for OpenPower machines"
+
+require skiboot.inc
+EXTRA_OEMAKE_append = " PFLASH_VERSION=${PV} LINKAGE=dynamic"
+
+#TODO: openbmc/openbmc#1361 - Fix GNU_HASH warnings in pflash
+TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/meta-openpower/recipes-bsp/skiboot/skiboot.inc b/meta-openpower/recipes-bsp/skiboot/skiboot.inc
new file mode 100644
index 000000000..169b207b7
--- /dev/null
+++ b/meta-openpower/recipes-bsp/skiboot/skiboot.inc
@@ -0,0 +1,27 @@
+HOMEPAGE = "https://github.com/open-power"
+LICENSE = "Apache-2.0"
+
+SRC_URI += "git://github.com/open-power/skiboot.git;nobranch=1"
+
+FILESEXTRAPATHS_append := "${THISDIR}/skiboot:"
+
+LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRCREV = "452998f4be5973d8884e3db5aa362bf40e11467a"
+PV = "v6.1"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SKIBOOT_VERSION=${PV} V=1"
+
+SKIBOOT_SUBDIR ?= "external/${PN}"
+
+do_compile() {
+ oe_runmake -C ${SKIBOOT_SUBDIR} all
+}
+
+# TODO: remove PREFIX=$prefix when updating to a version that has
+# http://patchwork.ozlabs.org/patch/923741/ is merged upstream
+do_install() {
+ oe_runmake -C ${SKIBOOT_SUBDIR} install DESTDIR=${D} prefix=/usr PREFIX=$prefix
+}
OpenPOWER on IntegriCloud