summaryrefslogtreecommitdiffstats
path: root/meta-openpower/recipes-bsp/fsidbg/fsidbg.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-bsp/fsidbg/fsidbg.bb')
-rw-r--r--meta-openpower/recipes-bsp/fsidbg/fsidbg.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/fsidbg/fsidbg.bb b/meta-openpower/recipes-bsp/fsidbg/fsidbg.bb
new file mode 100644
index 000000000..b6fed556a
--- /dev/null
+++ b/meta-openpower/recipes-bsp/fsidbg/fsidbg.bb
@@ -0,0 +1,18 @@
+SUMMARY = "FSI debug tool"
+DESCRIPTION = "fsidbg is a tool to access remote FSI engines and perform client driver operations"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
+
+SRC_URI += "git://github.com/eddiejames/fsidbg.git"
+
+SRCREV = "dfe278065c877724242dfae15a4c627fd2e3611c"
+PV = "git${SRCREV}"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 fsidbg ${D}${bindir}
+}
+
+TARGET_CC_ARCH += "${LDFLAGS}"
OpenPOWER on IntegriCloud