summaryrefslogtreecommitdiffstats
path: root/gprof/Makefile.am
diff options
context:
space:
mode:
authorJason Thorpe <thorpej@netbsd.org>2002-01-26 17:19:35 +0000
committerJason Thorpe <thorpej@netbsd.org>2002-01-26 17:19:35 +0000
commitec0806ec8163a1819054c7ac01dfd465d4b15aef (patch)
tree9c187a22f384ede7e8fc12e62c57dd786f13ad62 /gprof/Makefile.am
parent9cb61eabc1602dbecf3c3aa58c568284e76e6d7d (diff)
downloadppe42-binutils-ec0806ec8163a1819054c7ac01dfd465d4b15aef.tar.gz
ppe42-binutils-ec0806ec8163a1819054c7ac01dfd465d4b15aef.zip
* mips.c: New file.
* Makefile.am (sources): Add mips.c. (mips.o): New rule. * Makefile.in: Regenerate. * corefile.c: Update copyright years. (find_call): Call mips_find_call for bfd_arch_mips.
Diffstat (limited to 'gprof/Makefile.am')
-rw-r--r--gprof/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/gprof/Makefile.am b/gprof/Makefile.am
index b0b95c7132..4401e17530 100644
--- a/gprof/Makefile.am
+++ b/gprof/Makefile.am
@@ -23,7 +23,7 @@ bin_PROGRAMS = gprof
sources = basic_blocks.c call_graph.c cg_arcs.c cg_dfn.c \
cg_print.c corefile.c gmon_io.c gprof.c hertz.c hist.c source.c \
search_list.c symtab.c sym_ids.c utils.c \
- i386.c alpha.c vax.c tahoe.c sparc.c
+ i386.c alpha.c vax.c tahoe.c sparc.c mips.c
gprof_SOURCES = $(sources) flat_bl.c bsd_callg_bl.c fsf_callg_bl.c
gprof_DEPENDENCIES = ../bfd/libbfd.la ../libiberty/libiberty.a $(INTLDEPS)
gprof_LDADD = ../bfd/libbfd.la ../libiberty/libiberty.a $(INTLLIBS)
@@ -220,6 +220,11 @@ sparc.o: sparc.c gprof.h $(INCDIR)/ansidecl.h $(BFDDIR)/sysdep.h \
gconfig.h $(INCDIR)/bin-bugs.h cg_arcs.h symtab.h ../bfd/bfd.h \
$(INCDIR)/symcat.h source.h search_list.h corefile.h \
hist.h
+mips.o: mips.c gprof.h $(INCDIR)/ansidecl.h $(BFDDIR)/sysdep.h \
+ ../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
+ gconfig.h $(INCDIR)/bin-bugs.h cg_arcs.h symtab.h ../bfd/bfd.h \
+ $(INCDIR)/symcat.h source.h search_list.h corefile.h \
+ hist.h
flat_bl.o: flat_bl.c
bsd_callg_bl.o: bsd_callg_bl.c
fsf_callg_bl.o: fsf_callg_bl.c
OpenPOWER on IntegriCloud