summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 40b1ad6..45d9c0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,10 @@ AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
AM_SILENT_RULES([yes])
+# Modify header template
+AH_TOP([#pragma once])
+AH_BOTTOM([#include "workaround/systemd.h"])
+
# Checks for programs.
AC_PROG_CC
AM_PROG_AR
@@ -57,6 +61,16 @@ AC_DEFINE([MAPPER_BUSNAME], ["xyz.openbmc_project.ObjectMapper"], [Object mapper
AC_DEFINE([MAPPER_INTERFACE], ["xyz.openbmc_project.ObjectMapper"], [Object mapper interface])
AC_DEFINE([MAPPER_PATH], ["/xyz/openbmc_project/ObjectMapper"], [Object mapper DBUS path])
+# Workaround for unpatched systemd installs
+AC_ARG_ENABLE([unpatched-systemd],
+ AS_HELP_STRING([--enable-unpatched-systemd], [Enable unpatched systemd workarounds]))
+AS_IF([test "x$enable_unpatched_systemd" == "xyes"],
+ AC_MSG_NOTICE([Enabling unpatched systemd workarounds])
+ [
+ AC_DEFINE([IS_UNPATCHED_SYSTEMD], ,[Enable unpatched systemd workarounds])
+ ]
+)
+
# Create configured output
AC_CONFIG_FILES([Makefile setup.py])
AC_OUTPUT
OpenPOWER on IntegriCloud