summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2016-11-15 11:13:37 -0600
committerMatthew Barth <msbarth@us.ibm.com>2016-11-23 10:47:38 -0600
commitc6329c9c41f6735b546eecfd6941b1f3381f230a (patch)
treec741214c1d0ed88a3ce85f76b7c9b98a91fbc0f7 /configure.ac
parentf1d7c6e0512d04c520201f3b98d01a7e2a5c8fb5 (diff)
downloadphosphor-objmgr-c6329c9c41f6735b546eecfd6941b1f3381f230a.tar.gz
phosphor-objmgr-c6329c9c41f6735b546eecfd6941b1f3381f230a.zip
Workaround sd_bus_message_append_cmdline
Unable to get libmapper built without systemd being patched with the sd_bus_message_append_cmdline function. Until it is pushed upstream, this is a workaround to get the available systemd install built for unit testing. Change-Id: Ieca78955a4182eebd469a860c37ccaedfe75d323 Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 40b1ad6..45d9c0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,10 @@ AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
AM_SILENT_RULES([yes])
+# Modify header template
+AH_TOP([#pragma once])
+AH_BOTTOM([#include "workaround/systemd.h"])
+
# Checks for programs.
AC_PROG_CC
AM_PROG_AR
@@ -57,6 +61,16 @@ AC_DEFINE([MAPPER_BUSNAME], ["xyz.openbmc_project.ObjectMapper"], [Object mapper
AC_DEFINE([MAPPER_INTERFACE], ["xyz.openbmc_project.ObjectMapper"], [Object mapper interface])
AC_DEFINE([MAPPER_PATH], ["/xyz/openbmc_project/ObjectMapper"], [Object mapper DBUS path])
+# Workaround for unpatched systemd installs
+AC_ARG_ENABLE([unpatched-systemd],
+ AS_HELP_STRING([--enable-unpatched-systemd], [Enable unpatched systemd workarounds]))
+AS_IF([test "x$enable_unpatched_systemd" == "xyes"],
+ AC_MSG_NOTICE([Enabling unpatched systemd workarounds])
+ [
+ AC_DEFINE([IS_UNPATCHED_SYSTEMD], ,[Enable unpatched systemd workarounds])
+ ]
+)
+
# Create configured output
AC_CONFIG_FILES([Makefile setup.py])
AC_OUTPUT
OpenPOWER on IntegriCloud