summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index e3468a3..7fd38d1 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -8,7 +8,8 @@ check_PROGRAMS = \
serialization_test_properties \
remote_logging_test_address \
remote_logging_test_port \
- remote_logging_test_config
+ remote_logging_test_config \
+ sdjournal_mock_test
test_cppflags = \
-Igtest \
@@ -91,5 +92,11 @@ remote_logging_test_config_LDFLAGS = \
$(test_ldflags) \
-lstdc++fs
+sdjournal_mock_test_CPPFLAGS = $(test_cppflags)
+sdjournal_mock_test_CXXFLAGS = $(test_cxxflags)
+sdjournal_mock_test_SOURCES = sdtest.cpp
+sdjournal_mock_test_LDADD = $(top_builddir)/sdjournal.o
+sdjournal_mock_test_LDFLAGS = $(test_ldflags)
+
# TODO Remove once the test-case failure is resolved openbmc/phosphor-logging#11
XFAIL_TESTS = elog_errorwrap_test
OpenPOWER on IntegriCloud