summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-12-03 19:09:55 -0800
committerPatrick Venture <venture@google.com>2018-12-04 14:47:54 -0800
commit31552c05e2b7066e923389dc4bba421d0fbcf2df (patch)
treefb0d09dfc39329d1ad01dc33e0c63a1ca0ea4f50 /test/Makefile.am
parent7bb7a774544ca81b7a747f3014d3c23ce25ea848 (diff)
downloadphosphor-logging-31552c05e2b7066e923389dc4bba421d0fbcf2df.tar.gz
phosphor-logging-31552c05e2b7066e923389dc4bba421d0fbcf2df.zip
test: add test to force building of sdjournal mock
Add test to force building of sdjournal mock. This will ensure it won't break down chain users later. Change-Id: Ida9745595af251df800ec8e98abaa39728c9ba86 Signed-off-by: Patrick Venture <venture@google.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index e3468a3..7fd38d1 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -8,7 +8,8 @@ check_PROGRAMS = \
serialization_test_properties \
remote_logging_test_address \
remote_logging_test_port \
- remote_logging_test_config
+ remote_logging_test_config \
+ sdjournal_mock_test
test_cppflags = \
-Igtest \
@@ -91,5 +92,11 @@ remote_logging_test_config_LDFLAGS = \
$(test_ldflags) \
-lstdc++fs
+sdjournal_mock_test_CPPFLAGS = $(test_cppflags)
+sdjournal_mock_test_CXXFLAGS = $(test_cxxflags)
+sdjournal_mock_test_SOURCES = sdtest.cpp
+sdjournal_mock_test_LDADD = $(top_builddir)/sdjournal.o
+sdjournal_mock_test_LDFLAGS = $(test_ldflags)
+
# TODO Remove once the test-case failure is resolved openbmc/phosphor-logging#11
XFAIL_TESTS = elog_errorwrap_test
OpenPOWER on IntegriCloud