summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..c93a550
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,17 @@
+AM_DEFAULT_SOURCE_EXT = .cpp
+AM_CPPFLAGS = -I$(top_srcdir)/../sdbusplus
+
+BUILT_SOURCES = led-gen.hpp
+CLEANFILES = led-gen.hpp
+PYTHON="/usr/bin/python"
+led-gen.hpp: ${srcdir}/parse_led.py
+ ${AM_V_at}${PYTHON} $^ > $@
+
+sbin_PROGRAMS = \
+ ledmanager
+
+ledmanager_SOURCES = \
+ led-manager.cpp \
+ led-main.cpp
+
+ledmanager_LDFLAGS = $(SYSTEMD_LIBS)
OpenPOWER on IntegriCloud