summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2016-10-17 17:46:37 +0530
committerVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2016-11-21 23:06:00 +0530
commitb21fda795e15fb7ba3e74d63518ff2a112d4c875 (patch)
treeb4aeb74af1ee8ae06244b8af5e8381c879f63c6d /Makefile.am
parentcbad1b9813b5005fe6a2af706d777464cab5b845 (diff)
downloadphosphor-led-manager-b21fda795e15fb7ba3e74d63518ff2a112d4c875.tar.gz
phosphor-led-manager-b21fda795e15fb7ba3e74d63518ff2a112d4c875.zip
Add LED grouping support
This enables creating custom groups and participating LEDs so that it can later be generated from MRW. For each of the group, a dbus object is created which will announce LED actions. Fixes openbmc/openbmc#550 Change-Id: I7a56d08755288dcfce45ee4c6d6b6c5e5aa454f7 Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..c93a550
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,17 @@
+AM_DEFAULT_SOURCE_EXT = .cpp
+AM_CPPFLAGS = -I$(top_srcdir)/../sdbusplus
+
+BUILT_SOURCES = led-gen.hpp
+CLEANFILES = led-gen.hpp
+PYTHON="/usr/bin/python"
+led-gen.hpp: ${srcdir}/parse_led.py
+ ${AM_V_at}${PYTHON} $^ > $@
+
+sbin_PROGRAMS = \
+ ledmanager
+
+ledmanager_SOURCES = \
+ led-manager.cpp \
+ led-main.cpp
+
+ledmanager_LDFLAGS = $(SYSTEMD_LIBS)
OpenPOWER on IntegriCloud