summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 974623d..deda4ff 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -10,12 +10,15 @@ noinst_LTLIBRARIES = libtest.la
extra_yamldir=$(top_srcdir)/example/extra_interfaces.d
phosphor_inventory_test_SOURCES = test.cpp
-phosphor_inventory_test_LDADD = libtest.la
-phosphor_inventory_test_LDFLAGS = \
+phosphor_inventory_test_LDADD = \
+ libtest.la
$(SDBSUPLUS_LIBS) \
+ $(PTHREAD_LIBS)
+phosphor_inventory_test_CXXFLAGS = \
+ $(SDBUSPLUS_CFLAGS) \
$(PTHREAD_CFLAGS)
-phosphor_inventory_test_CFLAGS = $(SDBUSPLUS_CFLAGS)
+libtest_la_LDFLAGS = -static
libtest_la_SOURCES = \
extra_ifaces.cpp \
generated.cpp
OpenPOWER on IntegriCloud