summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-03-06 22:55:51 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-03-08 14:18:05 -0500
commitef2325d4633a7f7a2863a1c9e0fe20178ae7f24b (patch)
tree6382642c066a26c29de87a4407783de802eea01a /test/Makefile.am
parent3ea767d8945796a30fbe59c47d257e4e6d641458 (diff)
downloadphosphor-inventory-manager-ef2325d4633a7f7a2863a1c9e0fe20178ae7f24b.tar.gz
phosphor-inventory-manager-ef2325d4633a7f7a2863a1c9e0fe20178ae7f24b.zip
Build: Autotools usage improvements
Define CXXFLAGS rather than CFLAGS. Add libraries via LIBADD rather than LDFLAGS. This allows --as-needed to drop unnecessary libs if present. Don't bother with PIC objects for convenience library. Change-Id: I8e09a79a69b35be702811b594fed506332a23c43 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 974623d..deda4ff 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -10,12 +10,15 @@ noinst_LTLIBRARIES = libtest.la
extra_yamldir=$(top_srcdir)/example/extra_interfaces.d
phosphor_inventory_test_SOURCES = test.cpp
-phosphor_inventory_test_LDADD = libtest.la
-phosphor_inventory_test_LDFLAGS = \
+phosphor_inventory_test_LDADD = \
+ libtest.la
$(SDBSUPLUS_LIBS) \
+ $(PTHREAD_LIBS)
+phosphor_inventory_test_CXXFLAGS = \
+ $(SDBUSPLUS_CFLAGS) \
$(PTHREAD_CFLAGS)
-phosphor_inventory_test_CFLAGS = $(SDBUSPLUS_CFLAGS)
+libtest_la_LDFLAGS = -static
libtest_la_SOURCES = \
extra_ifaces.cpp \
generated.cpp
OpenPOWER on IntegriCloud