summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index b6e49b1..30353a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,17 +1,20 @@
sbin_PROGRAMS = phosphor-inventory
-phosphor_inventory_SOURCES = \
- app.cpp \
+phosphor_inventory_SOURCES = app.cpp
+phosphor_inventory_LDADD = libmanager.la
+
+noinst_LTLIBRARIES = libmanager.la
+libmanager_la_SOURCES = \
xyz.openbmc_project.Inventory.Manager.cpp \
generated.cpp \
manager.cpp
if EXAMPLE
-noinst_LTLIBRARIES = libexample.la
+noinst_LTLIBRARIES += libexample.la
libexample_la_SOURCES = \
- xyz.openbmc_project.Example.Iface1.cpp \
+ xyz.openbmc_project.Example.Iface1.cpp \
xyz.openbmc_project.Example.Iface2.cpp
-phosphor_inventory_LDADD = libexample.la
+libmanager_la_LIBADD = libexample.la
endif
phosphor_inventory_LDFLAGS = $(SYSTEMD_LIBS)
phosphor_inventory_CFLAGS = $(SYSTEMD_CFLAGS)
OpenPOWER on IntegriCloud