summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-10-31 13:20:02 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-11-08 15:15:36 -0500
commitd44683552c82cd7b9b85e15c83c5525eff63f804 (patch)
tree3d8cac2abc0a96c38ec2e0cdd6af74e8a90a2f16 /Makefile.am
parent624827a61fbcda5882bc1da51272fc19b709b6e8 (diff)
downloadphosphor-inventory-manager-d44683552c82cd7b9b85e15c83c5525eff63f804.tar.gz
phosphor-inventory-manager-d44683552c82cd7b9b85e15c83c5525eff63f804.zip
Put most objects in a library
For easy sharing with other Makefiles. Change-Id: I74635903be0119afcd13e1835cc4f28183f2c38b Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index b6e49b1..30353a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,17 +1,20 @@
sbin_PROGRAMS = phosphor-inventory
-phosphor_inventory_SOURCES = \
- app.cpp \
+phosphor_inventory_SOURCES = app.cpp
+phosphor_inventory_LDADD = libmanager.la
+
+noinst_LTLIBRARIES = libmanager.la
+libmanager_la_SOURCES = \
xyz.openbmc_project.Inventory.Manager.cpp \
generated.cpp \
manager.cpp
if EXAMPLE
-noinst_LTLIBRARIES = libexample.la
+noinst_LTLIBRARIES += libexample.la
libexample_la_SOURCES = \
- xyz.openbmc_project.Example.Iface1.cpp \
+ xyz.openbmc_project.Example.Iface1.cpp \
xyz.openbmc_project.Example.Iface2.cpp
-phosphor_inventory_LDADD = libexample.la
+libmanager_la_LIBADD = libexample.la
endif
phosphor_inventory_LDFLAGS = $(SYSTEMD_LIBS)
phosphor_inventory_CFLAGS = $(SYSTEMD_CFLAGS)
OpenPOWER on IntegriCloud