summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c1a9f7..e30d9e3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,14 @@ phosphor_inventory_SOURCES = \
xyz.openbmc_project.Inventory.Manager.cpp \
generated.cpp \
manager.cpp
+
+if EXAMPLE
+noinst_LTLIBRARIES = libexample.la
+libexample_la_SOURCES = \
+ xyz.openbmc_project.Example.Iface1.cpp \
+ xyz.openbmc_project.Example.Iface2.cpp
+phosphor_inventory_LDADD = libexample.la
+endif
phosphor_inventory_LDFLAGS = $(SYSTEMD_LIBS)
phosphor_inventory_CFLAGS = $(SYSTEMD_CFLAGS)
OpenPOWER on IntegriCloud