summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-10-31 10:24:27 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-11-08 15:15:36 -0500
commit64d994a61cbb8a2693f9d5d9413f7e09d851c53b (patch)
treeaa50ea6fcb687cb6ba7b8287331d451ade521bff /Makefile.am
parentd202bfdb3afb2b22a829307b81fc144731874c91 (diff)
downloadphosphor-inventory-manager-64d994a61cbb8a2693f9d5d9413f7e09d851c53b.tar.gz
phosphor-inventory-manager-64d994a61cbb8a2693f9d5d9413f7e09d851c53b.zip
Optionally include generated example bindings
Add an autoconf opttion that includes the example bindings, for use in standalone/testing environments. Change-Id: Id44f02a9bc7adcc8b36c09f0867ee1a663d7e25c Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c1a9f7..e30d9e3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,14 @@ phosphor_inventory_SOURCES = \
xyz.openbmc_project.Inventory.Manager.cpp \
generated.cpp \
manager.cpp
+
+if EXAMPLE
+noinst_LTLIBRARIES = libexample.la
+libexample_la_SOURCES = \
+ xyz.openbmc_project.Example.Iface1.cpp \
+ xyz.openbmc_project.Example.Iface2.cpp
+phosphor_inventory_LDADD = libexample.la
+endif
phosphor_inventory_LDFLAGS = $(SYSTEMD_LIBS)
phosphor_inventory_CFLAGS = $(SYSTEMD_CFLAGS)
OpenPOWER on IntegriCloud