summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 296165f..29f58e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,6 +255,17 @@ AC_ARG_ENABLE([transport_oem],
)
AM_CONDITIONAL([FEATURE_TRANSPORT_OEM], [test x$transport_oem = xtrue])
+# IPMI whitelist mechanism is not needed by everyone; offer a way to disable it
+AC_ARG_ENABLE([ipmi-whitelist],
+ [ --enable-ipmi-whitelist Enable/disable IPMI whitelist filtering],
+ [case "${enableval}" in
+ yes) ipmi_whitelist=true ;;
+ no) ipmi_whitelist=false ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-ipmi-whitelist]) ;;
+ esac],[ipmi_whitelist=true]
+ )
+AM_CONDITIONAL([FEATURE_IPMI_WHITELIST], [test x$ipmi_whitelist = xtrue])
+
# Create configured output
AC_CONFIG_FILES([
Makefile
OpenPOWER on IntegriCloud