summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVernon Mauery <vernon.mauery@linux.intel.com>2020-01-30 16:11:34 -0800
committerVernon Mauery <vernon.mauery@linux.intel.com>2020-02-05 17:03:54 +0000
commite9f8857a66c5df61a4e795a7d71b035fd89b92ef (patch)
tree0ccd5461d3bbb0df479821a894ebab9e528418e0 /configure.ac
parent930104a86aa997ba91bd6d588eb3abda39c2fa52 (diff)
downloadphosphor-host-ipmid-e9f8857a66c5df61a4e795a7d71b035fd89b92ef.tar.gz
phosphor-host-ipmid-e9f8857a66c5df61a4e795a7d71b035fd89b92ef.zip
Make ipmi whitelist optional
Not all users of ipmid want to use the whitelist. Or they want to have their own that behaves differently. This change makes it so one can disable the built-in whitelist so that OEMs can substitute their own custom filtering or use none at all. To disable the whitelist, pass --disable-ipmi-whitelist to configure. This can be done in Yocto via a bbappend for phosphor-ipmi-host: EXTRA_OECONF_append = " --disable-ipmi-whitelist" Tested: Built with and without the whitelist enabled to ensure that the whitelist is present when expected to be. Change-Id: I63f317b6c29ca73cc3296bb2fe38f836004ec35d Signed-off-by: Vernon Mauery <vernon.mauery@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 296165f..29f58e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,6 +255,17 @@ AC_ARG_ENABLE([transport_oem],
)
AM_CONDITIONAL([FEATURE_TRANSPORT_OEM], [test x$transport_oem = xtrue])
+# IPMI whitelist mechanism is not needed by everyone; offer a way to disable it
+AC_ARG_ENABLE([ipmi-whitelist],
+ [ --enable-ipmi-whitelist Enable/disable IPMI whitelist filtering],
+ [case "${enableval}" in
+ yes) ipmi_whitelist=true ;;
+ no) ipmi_whitelist=false ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-ipmi-whitelist]) ;;
+ esac],[ipmi_whitelist=true]
+ )
+AM_CONDITIONAL([FEATURE_IPMI_WHITELIST], [test x$ipmi_whitelist = xtrue])
+
# Create configured output
AC_CONFIG_FILES([
Makefile
OpenPOWER on IntegriCloud