summaryrefslogtreecommitdiffstats
path: root/softoff/test/Makefile.am
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-02-06 21:47:18 +0530
committerPatrick Williams <patrick@stwcx.xyz>2017-03-27 13:27:02 -0500
commit6dc96680f1e9db0d1c87ab26865a27ac80cefd3d (patch)
treec7ef0dd808c38a2a79f629a50dc1a530dc4813f2 /softoff/test/Makefile.am
parent31272b8475b63ae238219a30d2c01c58cc87c286 (diff)
downloadphosphor-host-ipmid-6dc96680f1e9db0d1c87ab26865a27ac80cefd3d.tar.gz
phosphor-host-ipmid-6dc96680f1e9db0d1c87ab26865a27ac80cefd3d.zip
Add gtest cases to verify sd_event timer
Change-Id: I6db746adc969a322f463c00143938c7c2339ff86 Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'softoff/test/Makefile.am')
-rw-r--r--softoff/test/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/softoff/test/Makefile.am b/softoff/test/Makefile.am
new file mode 100644
index 0000000..2c65568
--- /dev/null
+++ b/softoff/test/Makefile.am
@@ -0,0 +1,12 @@
+AM_CPPFLAGS = -I$(top_srcdir)/softoff
+
+# Run all 'check' test programs
+TESTS = $(check_PROGRAMS)
+
+# # Build/add utest to test suite
+check_PROGRAMS = utest
+utest_CPPFLAGS = -Igtest $(GTEST_CPPFLAGS) $(AM_CPPFLAGS)
+utest_CXXFLAGS = $(PTHREAD_CFLAGS)
+utest_LDFLAGS = -lgtest_main -lgtest $(PTHREAD_LIBS) $(OESDK_TESTCASE_FLAGS) $(SYSTEMD_LIBS) ${SDBUSPLUS_LIBS}
+utest_SOURCES = utest.cpp
+utest_LDADD = $(top_builddir)/softoff/timer.o
OpenPOWER on IntegriCloud