summaryrefslogtreecommitdiffstats
path: root/softoff/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'softoff/test/Makefile.am')
-rw-r--r--softoff/test/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/softoff/test/Makefile.am b/softoff/test/Makefile.am
new file mode 100644
index 0000000..2c65568
--- /dev/null
+++ b/softoff/test/Makefile.am
@@ -0,0 +1,12 @@
+AM_CPPFLAGS = -I$(top_srcdir)/softoff
+
+# Run all 'check' test programs
+TESTS = $(check_PROGRAMS)
+
+# # Build/add utest to test suite
+check_PROGRAMS = utest
+utest_CPPFLAGS = -Igtest $(GTEST_CPPFLAGS) $(AM_CPPFLAGS)
+utest_CXXFLAGS = $(PTHREAD_CFLAGS)
+utest_LDFLAGS = -lgtest_main -lgtest $(PTHREAD_LIBS) $(OESDK_TESTCASE_FLAGS) $(SYSTEMD_LIBS) ${SDBUSPLUS_LIBS}
+utest_SOURCES = utest.cpp
+utest_LDADD = $(top_builddir)/softoff/timer.o
OpenPOWER on IntegriCloud