summaryrefslogtreecommitdiffstats
path: root/monitor/Makefile.am
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-04-27 14:21:48 -0500
committerMatt Spinler <spinler@us.ibm.com>2017-05-11 13:52:50 -0500
commitebaae6115ff5248d7f46d065ca96229c1f4e583d (patch)
tree2c8771ab9f47db9c3a07aceb5cb2bba533346ba8 /monitor/Makefile.am
parentabf8da369cb1e7094cc00295131502c73ed5cbc1 (diff)
downloadphosphor-fan-presence-ebaae6115ff5248d7f46d065ca96229c1f4e583d.tar.gz
phosphor-fan-presence-ebaae6115ff5248d7f46d065ca96229c1f4e583d.zip
Add dbus support to TachSensor
TachSensor will match on properties changed signals for the Value and Target properties. When these occur, it will load in those properties and then tell the Fan class there was a change. Also, TachSensor will read in the Target property during construction so it will have a valid value to check against right away. Change-Id: I2dc2cacf5804826c6b0e0ea91196cbdaa4d5b893 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'monitor/Makefile.am')
-rw-r--r--monitor/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/monitor/Makefile.am b/monitor/Makefile.am
index 26b66b5..6c6f4b3 100644
--- a/monitor/Makefile.am
+++ b/monitor/Makefile.am
@@ -11,6 +11,7 @@ phosphor_fan_monitor_SOURCES = \
tach_sensor.cpp
phosphor_fan_monitor_LDADD = \
+ $(top_builddir)/libfan.la \
$(SDBUSPLUS_LIBS) \
$(PHOSPHOR_LOGGING_LIBS)
OpenPOWER on IntegriCloud