summaryrefslogtreecommitdiffstats
path: root/monitor/Makefile.am
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-04-27 14:08:45 -0500
committerMatt Spinler <spinler@us.ibm.com>2017-05-11 13:52:50 -0500
commitabf8da369cb1e7094cc00295131502c73ed5cbc1 (patch)
tree3e2d684c16cd62b457f31da1eab61b69acf698f2 /monitor/Makefile.am
parent35b156b79c1314de79e4728ef313f5164ae2ec32 (diff)
downloadphosphor-fan-presence-abf8da369cb1e7094cc00295131502c73ed5cbc1.tar.gz
phosphor-fan-presence-abf8da369cb1e7094cc00295131502c73ed5cbc1.zip
Fan and TachSensor class introduction
A Fan object has one or more TachSensor objects. The TachSensor class is used to keep track of the the actual and expected speeds. It only tracks expected speeds if the _hasTarget attribute is true. Future commits will add more functionality. Change-Id: I9bb5fac39f25c5c31c18457ebedf82838fcf6641 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'monitor/Makefile.am')
-rw-r--r--monitor/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/monitor/Makefile.am b/monitor/Makefile.am
index ceec3dd..26b66b5 100644
--- a/monitor/Makefile.am
+++ b/monitor/Makefile.am
@@ -5,8 +5,10 @@ sbin_PROGRAMS = \
phosphor-fan-monitor
phosphor_fan_monitor_SOURCES = \
+ fan.cpp \
generated.cpp \
- main.cpp
+ main.cpp \
+ tach_sensor.cpp
phosphor_fan_monitor_LDADD = \
$(SDBUSPLUS_LIBS) \
OpenPOWER on IntegriCloud