summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2017-05-23 22:48:11 -0500
committerJayanth Othayoth <ojayanth@in.ibm.com>2017-06-08 07:52:56 -0500
commit1756c067e7815fad9ef97cb955a25261a15ecea3 (patch)
tree6549b3ce7d172cd48f120ed8f5fb38a80bcb94a4 /configure.ac
parent23ebc262d2d3ede1dddf3fe0a6e93734cd985d9d (diff)
downloadphosphor-debug-collector-1756c067e7815fad9ef97cb955a25261a15ecea3.tar.gz
phosphor-debug-collector-1756c067e7815fad9ef97cb955a25261a15ecea3.zip
Initial commit for the Dump core file monitor infrastructure.
Add an inotify watch to the known core dump location. Resolves openbmc/openbmc#1504 Change-Id: I0093c9f601d82917ca2efb53a4d47ed98f0eaa7f Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9cf8ba2..fb1f382 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,10 +13,19 @@ AC_PROG_MKDIR_P
AC_CHECK_PROG([DIRNAME], dirname, dirname)
# Check for libraries
+PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221],,\
+ AC_MSG_ERROR(["systemd required and not found."]))
PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [phosphor-dbus-interfaces],,\
AC_MSG_ERROR(["Requires phosphor-dbus-interfaces package."]))
PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,\
AC_MSG_ERROR(["Requires sdbusplus package."]))
+PKG_CHECK_MODULES([PHOSPHOR_LOGGING], [phosphor-logging],,\
+ AC_MSG_ERROR(["Requires phosphor-logging package."]))
+
+# Check for sdbus++
+AC_PATH_PROG([SDBUSPLUSPLUS], [sdbus++])
+AS_IF([test "x$SDBUSPLUSPLUS" == "x"],
+ AC_MSG_ERROR(["Requires sdbus++"]))
# Check for sdbus++
AC_PATH_PROG([SDBUSPLUSPLUS], [sdbus++])
@@ -38,5 +47,9 @@ AC_ARG_VAR(DUMP_OBJPATH, [The Dump manager Dbus root])
AS_IF([test "x$DUMP_OBJPATH" == "x"], [DUMP_OBJPATH="/xyz/openbmc_project/dump"])
AC_DEFINE_UNQUOTED([DUMP_OBJPATH], ["$DUMP_OBJPATH"], [The dump manager Dbus root])
+AC_ARG_VAR(CORE_FILE_DIR, [Directory where core dumps are placed])
+AS_IF([test "x$CORE_FILE_DIR" == "x"], [CORE_FILE_DIR="/var/lib/systemd/coredump"])
+AC_DEFINE_UNQUOTED([CORE_FILE_DIR], ["$CORE_FILE_DIR"], [Directory where core dumps are placed])
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud