summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2017-05-25 07:22:03 -0500
committerJayanth Othayoth <ojayanth@in.ibm.com>2017-06-02 02:36:33 -0500
commit23ebc262d2d3ede1dddf3fe0a6e93734cd985d9d (patch)
treeac8b6d70972614710e6514eea7c2880566ac1cf4 /configure.ac
parent224882b0a744bbee8b1a8229f54a854cac4aea30 (diff)
downloadphosphor-debug-collector-23ebc262d2d3ede1dddf3fe0a6e93734cd985d9d.tar.gz
phosphor-debug-collector-23ebc262d2d3ede1dddf3fe0a6e93734cd985d9d.zip
Add internal interface to create BMC Dump based on the type.
Change-Id: I098e8b29834fd726574126ec589a883ba952b298 Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4082293..9cf8ba2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,13 +9,20 @@ AM_SILENT_RULES([yes])
AC_PROG_CXX
AC_PROG_INSTALL #Checks/sets the install variable to be used
AC_PROG_MAKE_SET
+AC_PROG_MKDIR_P
+AC_CHECK_PROG([DIRNAME], dirname, dirname)
# Check for libraries
PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [phosphor-dbus-interfaces],,\
AC_MSG_ERROR(["Requires phosphor-dbus-interfaces package."]))
-PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,
+PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,\
AC_MSG_ERROR(["Requires sdbusplus package."]))
+# Check for sdbus++
+AC_PATH_PROG([SDBUSPLUSPLUS], [sdbus++])
+AS_IF([test "x$SDBUSPLUSPLUS" == "x"],
+ AC_MSG_ERROR(["Requires sdbus++"]))
+
# Checks for library functions
LT_INIT # Required for systemd linking
OpenPOWER on IntegriCloud