summaryrefslogtreecommitdiffstats
path: root/support/dependencies
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2017-10-22 16:17:52 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2018-01-08 23:37:59 +0100
commit390780d5626f5d8613dab22928ae90051d169ab1 (patch)
tree57025cda33434be3c1fa2d92b365dd84512c6fb0 /support/dependencies
parent42decc07ce3efe5ec4b5d70016daca3e712451ef (diff)
downloadbuildroot-390780d5626f5d8613dab22928ae90051d169ab1.tar.gz
buildroot-390780d5626f5d8613dab22928ae90051d169ab1.zip
dependencies: correct dependencies for top-level parallel build
Commit 4932c8a7cc94277b3d53cecd935f725b91cfa9fe introduced the core-dependencies target to make sure that the dependencies.sh script runs before we attempt to compile any host tool, so that the absence of a compiler is properly detected. However, this relied on the left-to-right evaluation of dependencies. This will no longer be true when we enable top-level parallel build. Fix this by letting DEPENDENCIES_HOST_PREREQ depend on core-dependencies. Note that it is not possible to remove the dependencies <- core-dependencies. Indeed, it is possible that DEPENDENCIES_HOST_PREREQ is completely empty, and in that case we still need to check core-dependencies. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'support/dependencies')
-rw-r--r--support/dependencies/dependencies.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/support/dependencies/dependencies.mk b/support/dependencies/dependencies.mk
index 80ba48a6a7..4f606f849d 100644
--- a/support/dependencies/dependencies.mk
+++ b/support/dependencies/dependencies.mk
@@ -24,6 +24,8 @@ core-dependencies:
$(DEPENDENCIES_HOST_PREREQ): HOSTCC=$(HOSTCC_NOCCACHE)
$(DEPENDENCIES_HOST_PREREQ): HOSTCXX=$(HOSTCXX_NOCCACHE)
+$(DEPENDENCIES_HOST_PREREQ): core-dependencies
+
dependencies: core-dependencies $(DEPENDENCIES_HOST_PREREQ)
################################################################################
OpenPOWER on IntegriCloud