summaryrefslogtreecommitdiffstats
path: root/support/dependencies
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2017-10-22 16:17:51 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2018-01-08 23:37:54 +0100
commit42decc07ce3efe5ec4b5d70016daca3e712451ef (patch)
tree8ed1bada9292196c2633131d9f51aca7fb54c02f /support/dependencies
parent917de0f7322e91306bef757d51956ca873412b59 (diff)
downloadbuildroot-42decc07ce3efe5ec4b5d70016daca3e712451ef.tar.gz
buildroot-42decc07ce3efe5ec4b5d70016daca3e712451ef.zip
core-dependencies: remove unneeded HOSTCC
dependencies.sh uses HOSTCC_NOCCACHE directly, and this variable is exported from the top-level Makefile, so there is no need to pass HOSTCC to it. HOSTCC is not used at all in dependencies.sh. Thus, we also no longer need to apply the HOSTCC override for core-dependencies. The core-depencies rule doesn't use HOSTCC or HOSTCXX. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'support/dependencies')
-rw-r--r--support/dependencies/dependencies.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/support/dependencies/dependencies.mk b/support/dependencies/dependencies.mk
index ef2ae9b7e1..80ba48a6a7 100644
--- a/support/dependencies/dependencies.mk
+++ b/support/dependencies/dependencies.mk
@@ -19,12 +19,11 @@ DEPENDENCIES_HOST_PREREQ += host-ccache
endif
core-dependencies:
- @HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
- DL_TOOLS="$(sort $(DL_TOOLS_DEPENDENCIES))" \
+ @MAKE="$(MAKE)" DL_TOOLS="$(sort $(DL_TOOLS_DEPENDENCIES))" \
$(TOPDIR)/support/dependencies/dependencies.sh
-core-dependencies $(DEPENDENCIES_HOST_PREREQ): HOSTCC=$(HOSTCC_NOCCACHE)
-core-dependencies $(DEPENDENCIES_HOST_PREREQ): HOSTCXX=$(HOSTCXX_NOCCACHE)
+$(DEPENDENCIES_HOST_PREREQ): HOSTCC=$(HOSTCC_NOCCACHE)
+$(DEPENDENCIES_HOST_PREREQ): HOSTCXX=$(HOSTCXX_NOCCACHE)
dependencies: core-dependencies $(DEPENDENCIES_HOST_PREREQ)
################################################################################
OpenPOWER on IntegriCloud