summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMatt Weber <matthew.weber@rockwellcollins.com>2019-02-03 16:38:51 -0600
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2019-02-04 15:14:18 +0100
commitfcf9bcf014d654248dfc7d7fb6b7dbb34935e63e (patch)
tree9942c381224c542a003d4c5f934d5f14fb05a375 /package
parent9dcb5c581b8fddfdbbea5d2942618a5f0ddeceb9 (diff)
downloadbuildroot-fcf9bcf014d654248dfc7d7fb6b7dbb34935e63e.tar.gz
buildroot-fcf9bcf014d654248dfc7d7fb6b7dbb34935e63e.zip
package/ntp: use common sysv init install
Previously the sysv init script install was conditional based on ntpd being selected, now that sntp also has an init script and could be selected independent of ntpd, a common install is necessary. Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'package')
-rw-r--r--package/ntp/ntp.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/ntp/ntp.mk b/package/ntp/ntp.mk
index aad1cdd661..c62d59e81a 100644
--- a/package/ntp/ntp.mk
+++ b/package/ntp/ntp.mk
@@ -102,9 +102,8 @@ endef
endif
ifeq ($(BR2_PACKAGE_NTP_NTPD),y)
-define NTP_INSTALL_INIT_SYSV
+define NTP_INSTALL_INIT_SYSV_NTPD
$(INSTALL) -D -m 755 package/ntp/S49ntp $(TARGET_DIR)/etc/init.d/S49ntp
- $(NTP_INSTALL_INIT_SYSV_SNTP)
endef
define NTP_INSTALL_INIT_SYSTEMD
@@ -115,4 +114,9 @@ define NTP_INSTALL_INIT_SYSTEMD
endef
endif
+define NTP_INSTALL_INIT_SYSV
+ $(NTP_INSTALL_INIT_SYSV_NTPD)
+ $(NTP_INSTALL_INIT_SYSV_SNTP)
+endef
+
$(eval $(autotools-package))
OpenPOWER on IntegriCloud