summaryrefslogtreecommitdiffstats
path: root/package/ntp/ntp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/ntp/ntp.mk')
-rw-r--r--package/ntp/ntp.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/ntp/ntp.mk b/package/ntp/ntp.mk
index aad1cdd661..c62d59e81a 100644
--- a/package/ntp/ntp.mk
+++ b/package/ntp/ntp.mk
@@ -102,9 +102,8 @@ endef
endif
ifeq ($(BR2_PACKAGE_NTP_NTPD),y)
-define NTP_INSTALL_INIT_SYSV
+define NTP_INSTALL_INIT_SYSV_NTPD
$(INSTALL) -D -m 755 package/ntp/S49ntp $(TARGET_DIR)/etc/init.d/S49ntp
- $(NTP_INSTALL_INIT_SYSV_SNTP)
endef
define NTP_INSTALL_INIT_SYSTEMD
@@ -115,4 +114,9 @@ define NTP_INSTALL_INIT_SYSTEMD
endef
endif
+define NTP_INSTALL_INIT_SYSV
+ $(NTP_INSTALL_INIT_SYSV_NTPD)
+ $(NTP_INSTALL_INIT_SYSV_SNTP)
+endef
+
$(eval $(autotools-package))
OpenPOWER on IntegriCloud