summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-11-24 22:21:49 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-11-26 22:16:25 +0100
commite76d59c258f868f7958409d3c99e431596153645 (patch)
treed4bf1159bea1e1156a5488b0ea473ce75a3b46a3 /package
parenta36d751abd789fd54ef313c860db207bc28d3628 (diff)
downloadbuildroot-e76d59c258f868f7958409d3c99e431596153645.tar.gz
buildroot-e76d59c258f868f7958409d3c99e431596153645.zip
qt5base: support OVERRIDE_SRCDIR
With OVERRIDE_SRCDIR we don't apply any of the qt5base patches, but the custom specs files are needed to be able to build - So install these in the configure step instead of having them as a patch. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package')
-rw-r--r--package/qt5/qt5base/0002-mkspecs-files.patch41
-rw-r--r--package/qt5/qt5base/qmake.conf24
-rw-r--r--package/qt5/qt5base/qplatformdefs.h1
-rw-r--r--package/qt5/qt5base/qt5base.mk4
4 files changed, 29 insertions, 41 deletions
diff --git a/package/qt5/qt5base/0002-mkspecs-files.patch b/package/qt5/qt5base/0002-mkspecs-files.patch
deleted file mode 100644
index adeabdfbd8..0000000000
--- a/package/qt5/qt5base/0002-mkspecs-files.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Add a Buildroot 'device' to ease cross-compilation
-
-Qt5 has a mechanism to support "device" profiles, so that people can
-specify the compiler, compiler flags and so on for a specific device.
-
-We leverage this mechanism in the Buildroot packaging of qt5 to
-simplify cross-compilation: we have our own "device" definition, which
-allows us to easily pass the cross-compiler paths and flags from our
-qt5.mk.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-[Arnout: remove ccache support]
-Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
-
-Index: b/mkspecs/devices/linux-buildroot-g++/qmake.conf
-===================================================================
---- /dev/null
-+++ b/mkspecs/devices/linux-buildroot-g++/qmake.conf
-@@ -0,0 +1,16 @@
-+include(../common/linux_device_pre.conf)
-+
-+# modifications to g++-unix.conf
-+QMAKE_CC = $${CROSS_COMPILE}gcc
-+QMAKE_CXX = $${CROSS_COMPILE}g++
-+
-+#modifications to gcc-base.conf
-+QMAKE_CFLAGS += $${BR_COMPILER_CFLAGS}
-+QMAKE_CXXFLAGS += $${BR_COMPILER_CXXFLAGS}
-+QMAKE_CXXFLAGS_RELEASE += -O3
-+CONFIG += nostrip
-+
-+QMAKE_LIBS += -lrt -lpthread -ldl
-+
-+include(../common/linux_device_post.conf)
-+load(qt_config)
-Index: b/mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
-===================================================================
---- /dev/null
-+++ b/mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
-@@ -0,0 +1 @@
-+#include "../../linux-g++/qplatformdefs.h"
diff --git a/package/qt5/qt5base/qmake.conf b/package/qt5/qt5base/qmake.conf
new file mode 100644
index 0000000000..2152d3c7a4
--- /dev/null
+++ b/package/qt5/qt5base/qmake.conf
@@ -0,0 +1,24 @@
+# Qt5 has a mechanism to support "device" profiles, so that people can
+# specify the compiler, compiler flags and so on for a specific device.
+
+# We leverage this mechanism in the Buildroot packaging of qt5 to
+# simplify cross-compilation: we have our own "device" definition, which
+# allows us to easily pass the cross-compiler paths and flags from our
+# qt5.mk.
+
+include(../common/linux_device_pre.conf)
+
+# modifications to g++-unix.conf
+QMAKE_CC = $${CROSS_COMPILE}gcc
+QMAKE_CXX = $${CROSS_COMPILE}g++
+
+# modifications to gcc-base.conf
+QMAKE_CFLAGS += $${BR_COMPILER_CFLAGS}
+QMAKE_CXXFLAGS += $${BR_COMPILER_CXXFLAGS}
+QMAKE_CXXFLAGS_RELEASE += -O3
+CONFIG += nostrip
+
+QMAKE_LIBS += -lrt -lpthread -ldl
+
+include(../common/linux_device_post.conf)
+load(qt_config)
diff --git a/package/qt5/qt5base/qplatformdefs.h b/package/qt5/qt5base/qplatformdefs.h
new file mode 100644
index 0000000000..99e9a27923
--- /dev/null
+++ b/package/qt5/qt5base/qplatformdefs.h
@@ -0,0 +1 @@
+#include "../../linux-g++/qplatformdefs.h"
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 827a85e982..6eeb61973a 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -179,6 +179,10 @@ endef
endif
define QT5BASE_CONFIGURE_CMDS
+ $(INSTALL) -m 0644 -D $(QT5BASE_PKGDIR)/qmake.conf \
+ $(@D)/mkspecs/devices/linux-buildroot-g++/qmake.conf
+ $(INSTALL) -m 0644 -D $(QT5BASE_PKGDIR)/qplatformdefs.h \
+ $(@D)/mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
$(QT5BASE_CONFIGURE_CONFIG_FILE)
(cd $(@D); \
$(TARGET_MAKE_ENV) \
OpenPOWER on IntegriCloud