summaryrefslogtreecommitdiffstats
path: root/package/qt5/qt5base/qmake.conf
diff options
context:
space:
mode:
Diffstat (limited to 'package/qt5/qt5base/qmake.conf')
-rw-r--r--package/qt5/qt5base/qmake.conf24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/qt5/qt5base/qmake.conf b/package/qt5/qt5base/qmake.conf
new file mode 100644
index 0000000000..2152d3c7a4
--- /dev/null
+++ b/package/qt5/qt5base/qmake.conf
@@ -0,0 +1,24 @@
+# Qt5 has a mechanism to support "device" profiles, so that people can
+# specify the compiler, compiler flags and so on for a specific device.
+
+# We leverage this mechanism in the Buildroot packaging of qt5 to
+# simplify cross-compilation: we have our own "device" definition, which
+# allows us to easily pass the cross-compiler paths and flags from our
+# qt5.mk.
+
+include(../common/linux_device_pre.conf)
+
+# modifications to g++-unix.conf
+QMAKE_CC = $${CROSS_COMPILE}gcc
+QMAKE_CXX = $${CROSS_COMPILE}g++
+
+# modifications to gcc-base.conf
+QMAKE_CFLAGS += $${BR_COMPILER_CFLAGS}
+QMAKE_CXXFLAGS += $${BR_COMPILER_CXXFLAGS}
+QMAKE_CXXFLAGS_RELEASE += -O3
+CONFIG += nostrip
+
+QMAKE_LIBS += -lrt -lpthread -ldl
+
+include(../common/linux_device_post.conf)
+load(qt_config)
OpenPOWER on IntegriCloud