summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorTom Sparks <tom_a_sparks@yahoo.com.au>2015-08-08 22:42:14 +1000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-29 16:41:56 +0200
commitd45e6bf09d0413742457b371762b09e69cf22829 (patch)
tree48923a68ad1609b0e0000a30446e796f7e654e58 /package
parent721c78c9e05a49a3291364283225b552debb879e (diff)
downloadbuildroot-d45e6bf09d0413742457b371762b09e69cf22829.tar.gz
buildroot-d45e6bf09d0413742457b371762b09e69cf22829.zip
ibrcommon: new package
[Thomas: - add package in package/Config.in, to make it visible in menuconfig - make the openssl, libnl and libxml2 dependencies optional, since they are definitely not mandatory - add README to the license files, since it contains useful licensing related information. - remove custom INSTALL_STAGING_OPTS and INSTALL_TARGET_OPTS since the package uses automake. - add missing final newline in Config.in and .mk file.] Signed-off-by: Tom Sparks <tom_a_sparks@yahoo.com.au> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/Config.in1
-rw-r--r--package/ibrcommon/Config.in14
-rw-r--r--package/ibrcommon/ibrcommon.mk35
3 files changed, 50 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 68b3aa8f15..36f8f1c8c7 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -980,6 +980,7 @@ menu "Networking"
source "package/fmlib/Config.in"
source "package/geoip/Config.in"
source "package/glib-networking/Config.in"
+ source "package/ibrcommon/Config.in"
source "package/libcgi/Config.in"
source "package/libcgicc/Config.in"
source "package/libcurl/Config.in"
diff --git a/package/ibrcommon/Config.in b/package/ibrcommon/Config.in
new file mode 100644
index 0000000000..5aa51a45ff
--- /dev/null
+++ b/package/ibrcommon/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_IBRCOMMON
+ bool "ibrcommon"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ IBR-DTN is a small dtn application that supports:
+ Bundle Protocol RFC 5050
+ Bundle Security Protocol RFC 6257
+
+ http://trac.ibr.cs.tu-bs.de/project-cm-2012-ibrdtn
+
+comment "ibrcommon needs a toolchain w/ C++, threads"
+ depends on !BR2_INSTALL_LIBSTDCPP
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/ibrcommon/ibrcommon.mk b/package/ibrcommon/ibrcommon.mk
new file mode 100644
index 0000000000..282bfb0e59
--- /dev/null
+++ b/package/ibrcommon/ibrcommon.mk
@@ -0,0 +1,35 @@
+################################################################################
+#
+# ibrcommon
+#
+################################################################################
+
+IBRCOMMON_VERSION = 1.0.1
+IBRCOMMON_SOURCE = ibrcommon-$(IBRCOMMON_VERSION).tar.gz
+IBRCOMMON_SITE = https://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases/
+IBRCOMMON_INSTALL_STAGING = YES
+IBRCOMMON_LICENSE = Apache-2.0
+IBRCOMMON_LICENSE_FILES = COPYING README
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+IBRCOMMON_DEPENDENCIES += openssl
+IBRCOMMON_CONF_OPTS += --with-openssl
+else
+IBRCOMMON_CONF_OPTS += --without-openssl
+endif
+
+ifeq ($(BR2_PACKAGE_LIBNL),y)
+IBRCOMMON_DEPENDENCIES += libnl
+IBRCOMMON_CONF_OPTS += --with-lowpan
+else
+IBRCOMMON_CONF_OPTS += --without-lowpan
+endif
+
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+IBRCOMMON_DEPENDENCIES += libxml2
+IBRCOMMON_CONF_OPTS += --with-xml
+else
+IBRCOMMON_CONF_OPTS += --without-xml
+endif
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud