summaryrefslogtreecommitdiffstats
path: root/package/ibrcommon/ibrcommon.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/ibrcommon/ibrcommon.mk')
-rw-r--r--package/ibrcommon/ibrcommon.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/package/ibrcommon/ibrcommon.mk b/package/ibrcommon/ibrcommon.mk
new file mode 100644
index 0000000000..282bfb0e59
--- /dev/null
+++ b/package/ibrcommon/ibrcommon.mk
@@ -0,0 +1,35 @@
+################################################################################
+#
+# ibrcommon
+#
+################################################################################
+
+IBRCOMMON_VERSION = 1.0.1
+IBRCOMMON_SOURCE = ibrcommon-$(IBRCOMMON_VERSION).tar.gz
+IBRCOMMON_SITE = https://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases/
+IBRCOMMON_INSTALL_STAGING = YES
+IBRCOMMON_LICENSE = Apache-2.0
+IBRCOMMON_LICENSE_FILES = COPYING README
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+IBRCOMMON_DEPENDENCIES += openssl
+IBRCOMMON_CONF_OPTS += --with-openssl
+else
+IBRCOMMON_CONF_OPTS += --without-openssl
+endif
+
+ifeq ($(BR2_PACKAGE_LIBNL),y)
+IBRCOMMON_DEPENDENCIES += libnl
+IBRCOMMON_CONF_OPTS += --with-lowpan
+else
+IBRCOMMON_CONF_OPTS += --without-lowpan
+endif
+
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+IBRCOMMON_DEPENDENCIES += libxml2
+IBRCOMMON_CONF_OPTS += --with-xml
+else
+IBRCOMMON_CONF_OPTS += --without-xml
+endif
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud