summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2018-10-14 14:25:41 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-10-20 20:04:06 +0200
commit0c45649c12650e32966ae3c879595aea023d9331 (patch)
tree03c49c5b357821c772ae3bfa52566cebced39fc9 /package
parentda74078b341514096b306cba20386c9519c7ec30 (diff)
downloadbuildroot-0c45649c12650e32966ae3c879595aea023d9331.tar.gz
buildroot-0c45649c12650e32966ae3c879595aea023d9331.zip
legal-info: use the per-package variable to get the hash file
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Luca Ceresoli <luca@lucaceresoli.net> Cc: Baruch Siach <baruch@tkos.co.il> Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package')
-rw-r--r--package/pkg-generic.mk2
-rw-r--r--package/pkg-utils.mk8
2 files changed, 3 insertions, 7 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 7dfad2d1be..b8de0a9aac 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -912,7 +912,7 @@ ifneq ($$(call qstrip,$$($(2)_SOURCE)),)
ifeq ($$(call qstrip,$$($(2)_LICENSE_FILES)),)
$(Q)$$(call legal-warning-pkg,$$($(2)_BASENAME_RAW),cannot save license ($(2)_LICENSE_FILES not defined))
else
- $(Q)$$(foreach F,$$($(2)_LICENSE_FILES),$$(call legal-license-file,$$($(2)_RAWNAME),$$($(2)_BASENAME_RAW),$$($(2)_PKGDIR),$$(F),$$($(2)_DIR)/$$(F),$$(call UPPERCASE,$(4)))$$(sep))
+ $(Q)$$(foreach F,$$($(2)_LICENSE_FILES),$$(call legal-license-file,$$($(2)_RAWNAME),$$($(2)_BASENAME_RAW),$$($(2)_HASH_FILE),$$(F),$$($(2)_DIR)/$$(F),$$(call UPPERCASE,$(4)))$$(sep))
endif # license files
ifeq ($$($(2)_SITE_METHOD),local)
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index c3acc22b17..be287dc817 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -83,14 +83,10 @@ define legal-manifest # pkg, version, license, license-files, source, url, {HOST
echo '"$(1)","$(2)","$(3)","$(4)","$(5)","$(6)"' >>$(LEGAL_MANIFEST_CSV_$(7))
endef
-define legal-license-file # pkgname, pkgname-pkgver, pkgdir, filename, file-fullpath, {HOST|TARGET}
+define legal-license-file # pkgname, pkgname-pkgver, pkg-hashfile, filename, file-fullpath, {HOST|TARGET}
mkdir -p $(LICENSE_FILES_DIR_$(6))/$(2)/$(dir $(4)) && \
{ \
- if [ -f $(3)/$($(PKG)_VERSION)/$(1).hash ]; then \
- support/download/check-hash $(3)/$($(PKG)_VERSION)/$(1).hash $(5) $(4); \
- else \
- support/download/check-hash $(3)/$(1).hash $(5) $(4); \
- fi; \
+ support/download/check-hash $(3) $(5) $(4); \
case $${?} in (0|3) ;; (*) exit 1;; esac; \
} && \
cp $(5) $(LICENSE_FILES_DIR_$(6))/$(2)/$(4)
OpenPOWER on IntegriCloud