summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2018-10-14 14:25:40 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-10-20 20:04:06 +0200
commitda74078b341514096b306cba20386c9519c7ec30 (patch)
treeb8db0e1d5d2d592ec9ec71a64000fd8efcbf24df /package
parentb9203c9d6d7675fd898d06659bbbfa142ebb4e39 (diff)
downloadbuildroot-da74078b341514096b306cba20386c9519c7ec30.tar.gz
buildroot-da74078b341514096b306cba20386c9519c7ec30.zip
core: add a variable that points to the package's hash file
When a package has a version selection (e.g. Qt5), the licensing terms may be different across versions, but lie in similarly named files (e.g. 'LICENSE'). However, when we check a file, all the hashes for it must match. So, we can't have the hashes for two different content of the same file. We overcame that limitation in the legal-license-file macro, which checks whether a package has a .hash file in a versioned subdir. For consistency, we would like to also store the source hashes in that per-version subdir. Rather than reconstruct the path to the hash file everywhere we need it, add a variable that points to it. Existing users will be converted over in followup patches. Note: the check for a missing hash file is done in the check-hash helper script, so this variable must always yield a filename, even of a missing file, thus we do not use $(wildcard...) to resolve the hash file path; we use $(wildcard...) only to check if the versioned .hash file exists. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Luca Ceresoli <luca@lucaceresoli.net> Cc: Baruch Siach <baruch@tkos.co.il> Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package')
-rw-r--r--package/pkg-generic.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index daf24594de..7dfad2d1be 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -434,6 +434,12 @@ else
endif
$(2)_VERSION := $$(call sanitize,$$($(2)_DL_VERSION))
+$(2)_HASH_FILE = \
+ $$(strip \
+ $$(if $$(wildcard $$($(2)_PKGDIR)/$$($(2)_VERSION)/$$($(2)_RAWNAME).hash),\
+ $$($(2)_PKGDIR)/$$($(2)_VERSION)/$$($(2)_RAWNAME).hash,\
+ $$($(2)_PKGDIR)/$$($(2)_RAWNAME).hash))
+
ifdef $(3)_OVERRIDE_SRCDIR
$(2)_OVERRIDE_SRCDIR ?= $$($(3)_OVERRIDE_SRCDIR)
endif
OpenPOWER on IntegriCloud