summaryrefslogtreecommitdiffstats
path: root/package/pkg-download.mk
diff options
context:
space:
mode:
authorMarcin Nowakowski <marcin.nowakowski@imgtec.com>2017-09-07 08:31:06 +0200
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2017-09-24 13:11:55 +0200
commit1e5a8916b2ab4c9c99548fa6fbd4855eee323881 (patch)
treeaaa14026c166bb5129e001a8d94f1b20eaa91e07 /package/pkg-download.mk
parentf5ee77409ea06d084a8a57e3c2961c85af949113 (diff)
downloadbuildroot-1e5a8916b2ab4c9c99548fa6fbd4855eee323881.tar.gz
buildroot-1e5a8916b2ab4c9c99548fa6fbd4855eee323881.zip
pkg-download: remove explicit PKG_VERSION from github helper
Currently it is always required to add package version as an argument to the github helper. Since the version is always defined as PKG_VERSION, drop this argument and generate it automatically inside the helper routine. The github helper function is extended to support both 2 and 3 argument variants (ie. either use the provided package version argument or automatically substitute with PKG_VERSION if not available), which can make the transition of the package files easier as well allows using the 3-argument variant outside of package definitions. Signed-off-by: Marcin Nowakowski <marcin.nowakowski@imgtec.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'package/pkg-download.mk')
-rw-r--r--package/pkg-download.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index fbbc2d7391..dc4ff1c8c7 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -52,8 +52,8 @@ notdomain = $(patsubst $(call domain,$(1),$(2))$(call domainseparator,$(2))%,%,$
# default domainseparator is /, specify alternative value as first argument
domainseparator = $(if $(1),$(1),/)
-# github(user,package,version): returns site of GitHub repository
-github = https://github.com/$(1)/$(2)/archive/$(3)
+# github(user,package[,version]): returns site of GitHub repository
+github = https://github.com/$(1)/$(2)/archive/$(or $(3),$($(call UPPERCASE,$(pkgname))_VERSION))
# Expressly do not check hashes for those files
# Exported variables default to immediately expanded in some versions of
OpenPOWER on IntegriCloud