summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Nowakowski <marcin.nowakowski@imgtec.com>2017-09-07 08:31:06 +0200
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2017-09-24 13:11:55 +0200
commit1e5a8916b2ab4c9c99548fa6fbd4855eee323881 (patch)
treeaaa14026c166bb5129e001a8d94f1b20eaa91e07
parentf5ee77409ea06d084a8a57e3c2961c85af949113 (diff)
downloadbuildroot-1e5a8916b2ab4c9c99548fa6fbd4855eee323881.tar.gz
buildroot-1e5a8916b2ab4c9c99548fa6fbd4855eee323881.zip
pkg-download: remove explicit PKG_VERSION from github helper
Currently it is always required to add package version as an argument to the github helper. Since the version is always defined as PKG_VERSION, drop this argument and generate it automatically inside the helper routine. The github helper function is extended to support both 2 and 3 argument variants (ie. either use the provided package version argument or automatically substitute with PKG_VERSION if not available), which can make the transition of the package files easier as well allows using the 3-argument variant outside of package definitions. Signed-off-by: Marcin Nowakowski <marcin.nowakowski@imgtec.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
-rw-r--r--docs/manual/adding-packages-tips.txt5
-rw-r--r--package/pkg-download.mk4
2 files changed, 6 insertions, 3 deletions
diff --git a/docs/manual/adding-packages-tips.txt b/docs/manual/adding-packages-tips.txt
index 19577fa821..824f07547d 100644
--- a/docs/manual/adding-packages-tips.txt
+++ b/docs/manual/adding-packages-tips.txt
@@ -138,7 +138,7 @@ past, the 'github' helper function should be used as shown below.
------------------------
# Use a tag or a full commit ID
FOO_VERSION = v1.0
-FOO_SITE = $(call github,<user>,<package>,$(FOO_VERSION))
+FOO_SITE = $(call github,<user>,<package>[,<version>])
------------------------
.Notes
@@ -147,6 +147,9 @@ FOO_SITE = $(call github,<user>,<package>,$(FOO_VERSION))
Buildroot (e.g.: +foo-f6fb6654af62045239caed5950bc6c7971965e60.tar.gz+),
so it is not necessary to specify it in the +.mk+ file.
- When using a commit ID as version, you should use the full 40 hex characters.
+- The +version+ parameter is optional and should only be specified if anything
+ other than FOO_VERSION needs to be used, e.g. when this function is used to
+ specify a custom Linux or U-Boot tarball.
If the package you wish to add does have a release section on GitHub, the
maintainer may have uploaded a release tarball, or the release may just point
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index fbbc2d7391..dc4ff1c8c7 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -52,8 +52,8 @@ notdomain = $(patsubst $(call domain,$(1),$(2))$(call domainseparator,$(2))%,%,$
# default domainseparator is /, specify alternative value as first argument
domainseparator = $(if $(1),$(1),/)
-# github(user,package,version): returns site of GitHub repository
-github = https://github.com/$(1)/$(2)/archive/$(3)
+# github(user,package[,version]): returns site of GitHub repository
+github = https://github.com/$(1)/$(2)/archive/$(or $(3),$($(call UPPERCASE,$(pkgname))_VERSION))
# Expressly do not check hashes for those files
# Exported variables default to immediately expanded in some versions of
OpenPOWER on IntegriCloud