summaryrefslogtreecommitdiffstats
path: root/package/directfb/directfb.mk
diff options
context:
space:
mode:
authorCédric Marie <cedric.marie@openmailbox.org>2015-06-15 22:02:45 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-21 09:38:04 +0200
commitb488f356ed1a8ed9bd84d7e32203fe6730f261b6 (patch)
tree99b138065bb313251b93ca8eff8d9e2a96cc434c /package/directfb/directfb.mk
parente26ec6e45cb4246353bb4b88fbe718212fc89c61 (diff)
downloadbuildroot-b488f356ed1a8ed9bd84d7e32203fe6730f261b6.tar.gz
buildroot-b488f356ed1a8ed9bd84d7e32203fe6730f261b6.zip
directfb: add an option for debugging support
DirectFB provides two options for debug: * --enable-debug-support (default is yes) * --enable-debug (default is no) The first one provides the functions to print debug information. These functions can be called inside DirectFB, or by an external DirectFB driver in another package. The second one enables verbose mode in DirectFB, using these functions. Buildroot currently provides an option for the second one only. The first one - which is necessary for the second one - is always enabled, because this is the default value. The new option (BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT) makes it possible to disable debugging support (--disable-debug-support) in order to build the library with no debug feature at all. When debugging support is disabled, the target installation path of drivers (/usr/lib/directfb-<version>) is suffixed with -pure. The public library (/usr/lib/libdirectfb.so) remains unchanged. Some external DirectFB drivers will install into /usr/lib/directfb-<version>-pure in release mode. For that reason, it is important that DirectFB can be configured to use this directory. Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/directfb/directfb.mk')
-rw-r--r--package/directfb/directfb.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index e3dc506ae6..ad1dd18a28 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -39,9 +39,14 @@ DIRECTFB_CONF_OPTS += --enable-multi --enable-fusion
DIRECTFB_DEPENDENCIES += linux-fusion
endif
+ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT),y)
+DIRECTFB_CONF_OPTS += --enable-debug-support
ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG),y)
DIRECTFB_CONF_OPTS += --enable-debug
endif
+else
+DIRECTFB_CONF_OPTS += --disable-debug-support
+endif
ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
DIRECTFB_CONF_OPTS += --enable-trace
OpenPOWER on IntegriCloud