summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/directfb/Config.in14
-rw-r--r--package/directfb/directfb.mk5
2 files changed, 19 insertions, 0 deletions
diff --git a/package/directfb/Config.in b/package/directfb/Config.in
index 7759f8f11b..2b0d5c75a1 100644
--- a/package/directfb/Config.in
+++ b/package/directfb/Config.in
@@ -20,8 +20,22 @@ config BR2_PACKAGE_DIRECTFB_MULTI
comment "directfb multi application needs a Linux kernel to be built"
depends on !BR2_LINUX_KERNEL
+config BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
+ bool "directfb debugging support"
+ default y
+ help
+ Compile DirectFB with debugging support. It provides
+ functions to print debug information, for DirectFB as well as
+ external DirectFB drivers.
+
+ When disabled, DirectFB does not print any debug information.
+ The drivers will be installed to and loaded from
+ /usr/lib/directfb-<version>-pure instead of
+ /usr/lib/directfb-<version>.
+
config BR2_PACKAGE_DIRECTFB_DEBUG
bool "directfb debugging"
+ depends on BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
help
Compile DirectFB with lots of debug output
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index e3dc506ae6..ad1dd18a28 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -39,9 +39,14 @@ DIRECTFB_CONF_OPTS += --enable-multi --enable-fusion
DIRECTFB_DEPENDENCIES += linux-fusion
endif
+ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT),y)
+DIRECTFB_CONF_OPTS += --enable-debug-support
ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG),y)
DIRECTFB_CONF_OPTS += --enable-debug
endif
+else
+DIRECTFB_CONF_OPTS += --disable-debug-support
+endif
ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
DIRECTFB_CONF_OPTS += --enable-trace
OpenPOWER on IntegriCloud