summaryrefslogtreecommitdiffstats
path: root/test/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/lib/Makefile.am')
-rw-r--r--test/lib/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/test/lib/Makefile.am b/test/lib/Makefile.am
index 16052c6..3b4d8cb 100644
--- a/test/lib/Makefile.am
+++ b/test/lib/Makefile.am
@@ -20,10 +20,16 @@ AM_CPPFLAGS = \
AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
-list_test_SOURCES = list-test.c
-list_test_LDADD = ../../lib/libpbcore.la
+LDADD = ../../lib/libpbcore.la
-check_PROGRAMS = list-test
-TESTS = list-test
+check_PROGRAMS = list-test \
+ test-process-noargs \
+ test-process-sync \
+ test-process-sync-stdout \
+ test-process-async \
+ test-process-async-stdout \
+ test-process-both
+
+TESTS = $(check_PROGRAMS)
MAINTAINERCLEANFILES = Makefile.in
OpenPOWER on IntegriCloud