summaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorSam Mendoza-Jonas <sam@mendozajonas.com>2015-12-22 10:39:28 +0800
committerSam Mendoza-Jonas <sam@mendozajonas.com>2016-02-25 16:20:30 +1100
commit91ba67605de8ff5f15c335db4330594e07b5317e (patch)
tree0bb4e529257f29c3265fca958bd3e6de3b9c61a9 /utils/Makefile.am
parent7460bbb60ff7070c6884b700fc6370cd58703c4b (diff)
downloadtalos-petitboot-91ba67605de8ff5f15c335db4330594e07b5317e.tar.gz
talos-petitboot-91ba67605de8ff5f15c335db4330594e07b5317e.zip
utils/hooks: Write offb device address to device tree
On OpenPOWER machines, kernels missing the AST video driver can use the existing 'Open Firmware' framebuffer device code to inherit an existing framebuffer from Petitboot. This requires us to translate the 64-bit address of the framebuffer 'back' into a PCI address and write it into an assigned-addresses property in the device tree. Bootstrapped-by: Jeremy Kerr <jk@ozlabs.org> Signed-off-by: Sam Mendoza-Jonas <sam@mendozajonas.com>
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 9b36619..403f46d 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -19,6 +19,15 @@ sbin_PROGRAMS += utils/pb-event utils/pb-config
utils_pb_config_LDADD = $(top_builddir)/lib/libpbcore.la \
$(top_builddir)/discover/platform.ro
+utils_hooks_30_add_offb_SOURCES = utils/hooks/30-add-offb.c
+utils_hooks_30_add_offb_LDADD = $(top_builddir)/lib/libpbcore.la \
+ $(FDT_LIBS)
+
+if HAVE_LIBFDT
+noinst_PROGRAMS = \
+ utils/hooks/30-add-offb
+endif
+
dist_pkgdata_DATA = \
utils/kboot.conf.sample \
utils/bb-kexec-reboot \
OpenPOWER on IntegriCloud