summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorSamuel Mendoza-Jonas <sam@mendozajonas.com>2018-06-19 16:33:42 +1000
committerSamuel Mendoza-Jonas <sam@mendozajonas.com>2018-12-03 14:39:57 +1100
commit5d7f93f2ee09de515e1e474fd752d52590b51793 (patch)
treee125ada614a82edd27269b873d77a66d99420da0 /lib/Makefile.am
parentcfd6bf4f7da1ee71a65f57f28912d43ab757b968 (diff)
downloadtalos-petitboot-5d7f93f2ee09de515e1e474fd752d52590b51793.tar.gz
talos-petitboot-5d7f93f2ee09de515e1e474fd752d52590b51793.zip
lib/crypt: Add helpers for operating on /etc/shadow
Provides helper functions for reading, writing, and checking against /etc/shadow. The main use case if for authenticating clients against the "system" password, which is set as the root password. Signed-off-by: Samuel Mendoza-Jonas <sam@mendozajonas.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 016a14d..69a66c3 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -35,6 +35,7 @@ lib_libpbcore_la_CFLAGS = \
lib_libpbcore_la_SOURCES = \
lib/ccan/endian/endian.h \
+ lib/crypt/crypt.h \
lib/file/file.h \
lib/file/file.c \
lib/fold/fold.h \
@@ -93,3 +94,11 @@ lib_libpbcore_la_SOURCES += \
lib/security/none.c
endif
endif
+
+if ENABLE_CRYPT
+lib_libpbcore_la_SOURCES += \
+ lib/crypt/crypt.c
+
+lib_libpbcore_la_LDFLAGS += \
+ $(CRYPT_LIBS)
+endif
OpenPOWER on IntegriCloud