summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGeoff Levand <geoff@infradead.org>2012-02-12 12:12:32 -0800
committerGeoff Levand <geoff@infradead.org>2012-02-12 12:12:32 -0800
commit6532debf0bd95509cff9eb8634f57aef20a696b9 (patch)
tree855729e1f3a7179bc9bb94152d0a5af4234f9fcd /Makefile.am
parent174887a55ad4e8cbacde32de207c3deef8711fab (diff)
downloadtalos-petitboot-6532debf0bd95509cff9eb8634f57aef20a696b9.tar.gz
talos-petitboot-6532debf0bd95509cff9eb8634f57aef20a696b9.zip
Convert build to use automake
Signed-off-by: Geoff Levand <geoff@infradead.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a89b0b0
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,33 @@
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+
+SUBDIRS = lib discover ui utils man
+
+ACLOCAL_AMFLAGS = -I m4
+
+AM_CPPFLAGS = $(DEFAULT_CPPFLAGS)
+AM_CFLAGS = $(DEFAULT_CFLAGS)
+
+LIBTOOL_DEPS = @LIBTOOL_DEPS@
+
+libtool: $(LIBTOOL_DEPS)
+ $(SHELL) ./config.status libtool
+
+EXTRA_DIST = bootstrap configure.ac.in
+
+MAINTAINERCLEANFILES = aclocal.m4 config.* configure configure.ac depcomp \
+ install-sh ltmain.sh Makefile.in missing $(PACKAGE)-*.gz
+
+maintainer-clean-local:
+ rm -rf m4
OpenPOWER on IntegriCloud