summaryrefslogtreecommitdiffstats
path: root/yocto-poky/meta-skeleton/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta-skeleton/recipes-kernel/linux')
-rw-r--r--yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb71
-rw-r--r--yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch29
-rw-r--r--yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/feature.scc1
-rw-r--r--yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/smp.cfg1
4 files changed, 0 insertions, 102 deletions
diff --git a/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
deleted file mode 100644
index 6194d4f8d..000000000
--- a/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
+++ /dev/null
@@ -1,71 +0,0 @@
-# linux-yocto-custom.bb:
-#
-# An example kernel recipe that uses the linux-yocto and oe-core
-# kernel classes to apply a subset of yocto kernel management to git
-# managed kernel repositories.
-#
-# To use linux-yocto-custom in your layer, copy this recipe (optionally
-# rename it as well) and modify it appropriately for your machine. i.e.:
-#
-# COMPATIBLE_MACHINE_yourmachine = "yourmachine"
-#
-# You must also provide a Linux kernel configuration. The most direct
-# method is to copy your .config to files/defconfig in your layer,
-# in the same directory as the copy (and rename) of this recipe and
-# add file://defconfig to your SRC_URI.
-#
-# To use the yocto kernel tooling to generate a BSP configuration
-# using modular configuration fragments, see the yocto-bsp and
-# yocto-kernel tools documentation.
-#
-# Warning:
-#
-# Building this example without providing a defconfig or BSP
-# configuration will result in build or boot errors. This is not a
-# bug.
-#
-#
-# Notes:
-#
-# patches: patches can be merged into to the source git tree itself,
-# added via the SRC_URI, or controlled via a BSP
-# configuration.
-#
-# defconfig: When a defconfig is provided, the linux-yocto configuration
-# uses the filename as a trigger to use a 'allnoconfig' baseline
-# before merging the defconfig into the build.
-#
-# If the defconfig file was created with make_savedefconfig,
-# not all options are specified, and should be restored with their
-# defaults, not set to 'n'. To properly expand a defconfig like
-# this, specify: KCONFIG_MODE="--alldefconfig" in the kernel
-# recipe.
-#
-# example configuration addition:
-# SRC_URI += "file://smp.cfg"
-# example patch addition (for kernel v4.x only):
-# SRC_URI += "file://0001-linux-version-tweak.patch"
-# example feature addition (for kernel v4.x only):
-# SRC_URI += "file://feature.scc"
-#
-
-inherit kernel
-require recipes-kernel/linux/linux-yocto.inc
-
-# Override SRC_URI in a copy of this recipe to point at a different source
-# tree if you do not want to build from Linus' tree.
-SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine"
-
-LINUX_VERSION ?= "4.2"
-LINUX_VERSION_EXTENSION_append = "-custom"
-
-# Modify SRCREV to a different commit hash in a copy of this recipe to
-# build a different release of the Linux kernel.
-# tag: v4.2 64291f7db5bd8150a74ad2036f1037e6a0428df2
-SRCREV_machine="64291f7db5bd8150a74ad2036f1037e6a0428df2"
-
-PV = "${LINUX_VERSION}+git${SRCPV}"
-
-# Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe
-# file. Leaving it empty here ensures an early explicit build failure.
-COMPATIBLE_MACHINE = "(^$)"
diff --git a/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch b/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch
deleted file mode 100644
index 1c88315cd..000000000
--- a/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From fb2c401374d4efe89e8da795e21d96fac038639d Mon Sep 17 00:00:00 2001
-From: Bruce Ashfield <bruce.ashfield@windriver.com>
-Date: Mon, 11 Jun 2012 15:31:42 -0400
-Subject: [PATCH] linux: version tweak
-
-Upstream-Status: Inappropriate [example code]
-
-Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index c361593..099e8ff 100644
---- a/Makefile
-+++ b/Makefile
-@@ -2,7 +2,7 @@ VERSION = 4
- PATCHLEVEL = 2
- SUBLEVEL = 0
- EXTRAVERSION =
--NAME = Hurr durr I'ma sheep
-+NAME = Hurr durr I'ma customized sheep
-
- # *DOCUMENTATION*
- # To see a list of typical targets execute "make help"
---
-2.1.4
-
diff --git a/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/feature.scc b/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/feature.scc
deleted file mode 100644
index aad5af49f..000000000
--- a/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/feature.scc
+++ /dev/null
@@ -1 +0,0 @@
-patch 0001-linux-version-tweak.patch
diff --git a/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/smp.cfg b/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/smp.cfg
deleted file mode 100644
index 0c26a8626..000000000
--- a/yocto-poky/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/smp.cfg
+++ /dev/null
@@ -1 +0,0 @@
-# CONFIG_SMP is not set
OpenPOWER on IntegriCloud