summaryrefslogtreecommitdiffstats
path: root/poky/meta/recipes-support/user-creation/xuser-account_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-support/user-creation/xuser-account_0.1.bb')
-rw-r--r--poky/meta/recipes-support/user-creation/xuser-account_0.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/poky/meta/recipes-support/user-creation/xuser-account_0.1.bb b/poky/meta/recipes-support/user-creation/xuser-account_0.1.bb
new file mode 100644
index 000000000..81817d1e2
--- /dev/null
+++ b/poky/meta/recipes-support/user-creation/xuser-account_0.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Creates an 'xuser' account used for running X11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://system-xuser.conf"
+
+inherit allarch useradd
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ :
+}
+
+do_install() {
+ install -D -m 0644 ${WORKDIR}/system-xuser.conf ${D}${sysconfdir}/dbus-1/system.d/system-xuser.conf
+}
+
+FILES_${PN} = "${sysconfdir}/dbus-1/system.d/system-xuser.conf"
+
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "--create-home \
+ --groups video,tty,audio,input,shutdown,disk \
+ --user-group xuser"
+
+ALLOW_EMPTY_${PN} = "1"
OpenPOWER on IntegriCloud