summaryrefslogtreecommitdiffstats
path: root/poky/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb')
-rw-r--r--poky/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/poky/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb b/poky/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
new file mode 100644
index 000000000..224428ddd
--- /dev/null
+++ b/poky/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2007-2008 OpenedHand Ltd.
+#
+
+SUMMARY = "Sato desktop"
+PR = "r33"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup distro_features_check
+REQUIRED_DISTRO_FEATURES = "x11"
+
+PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
+
+RDEPENDS_${PN} = "\
+ ${PN}-base \
+ ${PN}-apps \
+ ${PN}-games \
+ "
+
+NETWORK_MANAGER ?= "connman-gnome"
+
+SUMMARY_${PN}-base = "Sato desktop - base packages"
+RDEPENDS_${PN}-base = "\
+ matchbox-desktop \
+ matchbox-session-sato \
+ matchbox-keyboard \
+ matchbox-keyboard-applet \
+ matchbox-keyboard-im \
+ matchbox-config-gtk \
+ xcursor-transparent-theme \
+ adwaita-icon-theme \
+ settings-daemon \
+ shutdown-desktop \
+ libsdl \
+ ${NETWORK_MANAGER} \
+ udev-extraconf \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-server pulseaudio-client-conf-sato pulseaudio-misc', '', d)} \
+ "
+
+FILEMANAGER ?= "pcmanfm"
+
+WEB ?= ""
+#WEB = "epiphany"
+
+SUMMARY_${PN}-apps = "Sato desktop - applications"
+RDEPENDS_${PN}-apps = "\
+ l3afpad \
+ gst-examples \
+ matchbox-terminal \
+ sato-screenshot \
+ ${FILEMANAGER} \
+ ${WEB} \
+ "
+
+SUMMARY_${PN}-games = "Sato desktop - games"
+RDEPENDS_${PN}-games = "\
+ puzzles \
+ "
OpenPOWER on IntegriCloud