summaryrefslogtreecommitdiffstats
path: root/poky/meta/recipes-graphics/pong-clock/pong-clock_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-graphics/pong-clock/pong-clock_1.0.bb')
-rw-r--r--poky/meta/recipes-graphics/pong-clock/pong-clock_1.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/poky/meta/recipes-graphics/pong-clock/pong-clock_1.0.bb b/poky/meta/recipes-graphics/pong-clock/pong-clock_1.0.bb
new file mode 100644
index 000000000..cdfe38a22
--- /dev/null
+++ b/poky/meta/recipes-graphics/pong-clock/pong-clock_1.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A clock combined with a game of pong"
+LICENSE = "GPLv2+"
+DEPENDS = "virtual/libx11 xdmcp xau"
+
+inherit distro_features_check pkgconfig
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI = "file://pong-clock-no-flicker.c"
+
+LIC_FILES_CHKSUM = "file://pong-clock-no-flicker.c;beginline=1;endline=23;md5=dd248d50f73f746d1ee78586b0b2ebd3"
+
+S = "${WORKDIR}"
+
+do_compile () {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o pong-clock pong-clock-no-flicker.c `pkg-config --cflags --libs x11 xau xdmcp`
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 pong-clock ${D}${bindir}
+}
OpenPOWER on IntegriCloud