summaryrefslogtreecommitdiffstats
path: root/poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb')
-rw-r--r--poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb b/poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
new file mode 100644
index 000000000..001db9e5e
--- /dev/null
+++ b/poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2011 Intel Corporation
+#
+
+PR = "r40"
+
+inherit packagegroup distro_features_check
+REQUIRED_DISTRO_FEATURES = "x11"
+
+PACKAGES = "${PN} ${PN}-utils"
+
+# backwards compatibility for xserver-common
+VIRTUAL-RUNTIME_xserver_common ?= ""
+
+# elsa, xserver-nodm-init
+VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
+
+SUMMARY = "X11 display server and basic utilities"
+RDEPENDS_${PN} = "\
+ ${PN}-xserver \
+ ${PN}-utils \
+ "
+
+SUMMARY_${PN}-utils = "X11 basic utilities and init"
+RDEPENDS_${PN}-utils = "\
+ ${VIRTUAL-RUNTIME_xserver_common} \
+ ${VIRTUAL-RUNTIME_graphical_init_manager} \
+ xauth \
+ xhost \
+ xset \
+ xrandr \
+ xmodmap \
+ xdpyinfo \
+ xinput-calibrator \
+ dbus-x11 \
+ "
OpenPOWER on IntegriCloud