summaryrefslogtreecommitdiffstats
path: root/poky/meta/recipes-devtools/devel-config/distcc-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/devel-config/distcc-config.bb')
-rw-r--r--poky/meta/recipes-devtools/devel-config/distcc-config.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/devel-config/distcc-config.bb b/poky/meta/recipes-devtools/devel-config/distcc-config.bb
new file mode 100644
index 000000000..3cd661d54
--- /dev/null
+++ b/poky/meta/recipes-devtools/devel-config/distcc-config.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Sets up distcc for compilation on the target device"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://distcc.sh"
+
+S = "${WORKDIR}"
+
+# Default to the host machine for a running qemu session
+DISTCC_HOSTS ?= "192.168.7.1"
+
+do_configure() {
+ sed -i "s%@DISTCC_HOSTS@%${DISTCC_HOSTS}%" distcc.sh
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/profile.d
+ install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
+}
+
+RDEPENDS_${PN} = "distcc"
OpenPOWER on IntegriCloud