summaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-bsp')
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb10
-rw-r--r--meta-raspberrypi/recipes-bsp/common/firmware.inc8
-rw-r--r--meta-raspberrypi/recipes-bsp/formfactor/formfactor/rpi/machconfig (renamed from meta-raspberrypi/recipes-bsp/formfactor/formfactor/raspberrypi/machconfig)0
-rw-r--r--meta-raspberrypi/recipes-bsp/formfactor/formfactor_%.bbappend (renamed from meta-raspberrypi/recipes-bsp/formfactor/formfactor_0.0.bbappend)0
-rw-r--r--meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb2
5 files changed, 13 insertions, 7 deletions
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index e0b2b58bc..a85c91630 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Commented config.txt file for the Raspberry Pi. \
the ARM core is initialised. It can be used to set various \
system configuration parameters."
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
COMPATIBLE_MACHINE = "^rpi$"
@@ -177,7 +177,13 @@ do_deploy() {
echo "# Enable USB peripheral mode" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dtoverlay=dwc2,dr_mode=peripheral" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi
-
+
+ # AT86RF23X support
+ if [ "${ENABLE_AT86RF}" = "1" ]; then
+ echo "# Enable AT86RF23X" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=at86rf233,speed=3000000" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
# Append extra config if the user has provided any
echo "${RPI_EXTRA_CONFIG}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
}
diff --git a/meta-raspberrypi/recipes-bsp/common/firmware.inc b/meta-raspberrypi/recipes-bsp/common/firmware.inc
index d564a49ab..26cafb746 100644
--- a/meta-raspberrypi/recipes-bsp/common/firmware.inc
+++ b/meta-raspberrypi/recipes-bsp/common/firmware.inc
@@ -1,10 +1,10 @@
-RPIFW_DATE ?= "20180417"
-SRCREV ?= "5db8e4e1c63178e200d6fbea23ed4a9bf4656658"
+RPIFW_DATE ?= "20180619"
+SRCREV ?= "748fb17992426bb29d99224b93cb962fefbdc833"
RPIFW_SRC_URI ?= "https://github.com/raspberrypi/firmware/archive/${SRCREV}.tar.gz"
RPIFW_S ?= "${WORKDIR}/firmware-${SRCREV}"
SRC_URI = "${RPIFW_SRC_URI}"
-SRC_URI[md5sum] = "6bce52f22a7a005a9bcdb9912b132590"
-SRC_URI[sha256sum] = "84568c4e7f5b0deee4cd76e7c0b48315885f983d6131d8148ef8af8438328a36"
+SRC_URI[md5sum] = "02edb854e9b72499225f3f93d322fe12"
+SRC_URI[sha256sum] = "07b2dc9d0779e15666e3ab596387e18cefc265d863c4bf6f8a0572b58a4fb793"
PV = "${RPIFW_DATE}"
diff --git a/meta-raspberrypi/recipes-bsp/formfactor/formfactor/raspberrypi/machconfig b/meta-raspberrypi/recipes-bsp/formfactor/formfactor/rpi/machconfig
index bef4ce3c9..bef4ce3c9 100644
--- a/meta-raspberrypi/recipes-bsp/formfactor/formfactor/raspberrypi/machconfig
+++ b/meta-raspberrypi/recipes-bsp/formfactor/formfactor/rpi/machconfig
diff --git a/meta-raspberrypi/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-raspberrypi/recipes-bsp/formfactor/formfactor_%.bbappend
index 72d991c7e..72d991c7e 100644
--- a/meta-raspberrypi/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ b/meta-raspberrypi/recipes-bsp/formfactor/formfactor_%.bbappend
diff --git a/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb b/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
index 0106ac3ff..593fc903e 100644
--- a/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
+++ b/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
@@ -1,6 +1,6 @@
SUMMARY = "U-boot boot scripts for Raspberry Pi"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
COMPATIBLE_MACHINE = "^rpi$"
DEPENDS = "u-boot-mkimage-native"
OpenPOWER on IntegriCloud